summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec')
-rw-r--r--redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec144
1 files changed, 103 insertions, 41 deletions
diff --git a/redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec b/redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec
index 38e835e4e..353512089 100644
--- a/redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec
+++ b/redhat/main/tdeadmin/tdeadmin-3.5.13.2.spec
@@ -1,43 +1,60 @@
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
+#
+# spec file for package tdeadmin (version 3.5.13-SRU)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# BUILD WARNING:
+# Remove qt-devel and qt3-devel and any kde*-devel on your system !
+# Having KDE libraries may cause FTBFS here !
+
+# TDE variables
+%define tde_epoch 1
%define tde_version 3.5.13.2
-
-# TDE specific building variables
+%define tde_pkg tdeadmin
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_sbindir %{tde_prefix}/sbin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
-
+%define tde_sbindir %{tde_prefix}/sbin
%define tde_tdeappdir %{tde_datadir}/applications/kde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-
-Name: trinity-tdeadmin
-Summary: Administrative tools for TDE
-Version: %{tde_version}
-Release: %{?!preversion:2}%{?preversion:1_%{preversion}}%{?dist}%{?_variant}
-License: GPLv2
-Group: User Interface/Desktops
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Name: trinity-%{tde_pkg}
+Summary: Administrative tools for TDE
+Version: %{tde_version}
+Release: %{?!preversion:3}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Group: System/GUI/Other
+URL: http://www.trinitydesktop.org/
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Prefix: %{tde_prefix}
+#Vendor: Trinity Project
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Obsoletes: trinity-kdeadmin < %{version}-%{release}
-Provides: trinity-kdeadmin = %{version}-%{release}
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
Source1: kuser.pam
@@ -46,17 +63,39 @@ Source5: kpackagerc
Source6: ksysvrc
Source7: kuserrc
-BuildRequires: autoconf automake libtool m4
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+Obsoletes: trinity-kdeadmin < %{version}-%{release}
+Provides: trinity-kdeadmin = %{version}-%{release}
+
+BuildRequires: trinity-arts-devel >= %{tde_epoch}:1.5.10
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libtool
+BuildRequires: m4
+BuildRequires: fdupes
+BuildRequires: gcc-c++
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# RPM support
BuildRequires: rpm-devel
+
+# PAM support
BuildRequires: pam-devel
+# LILO support
%if 0%{?mgaversion} || 0%{?mdkversion} || 0%{?suse_version}
-%define with_lilo 1
+#define with_lilo 1
%endif
-
%if 0%{?with_lilo}
BuildRequires: lilo
%endif
@@ -70,6 +109,8 @@ Requires: trinity-ksysv = %{version}-%{release}
Requires: trinity-kuser = %{version}-%{release}
%if 0%{?with_lilo}
Requires: trinity-lilo-config = %{version}-%{release}
+%else
+Obsoletes: trinity-lilo-config
%endif
# CONSOLEHELPER (usermode) support
@@ -96,7 +137,7 @@ kcron, kdat, knetworkconf, kpackage, ksysv, kuser.
%package -n trinity-kcron
Summary: The Trinity crontab editor
-Group: Applications/Utilities
+Group: System/GUI/Other
%description -n trinity-kcron
KCron is an application for scheduling programs to run in the background.
@@ -106,7 +147,7 @@ It is a graphical user interface to cron, the UNIX system scheduler.
%defattr(-,root,root,-)
%{tde_bindir}/kcron
%{tde_tdeappdir}/kcron.desktop
-%{tde_datadir}/apps/kcron/kcronui.rc
+%{tde_datadir}/apps/kcron/
%{tde_datadir}/icons/hicolor/*/apps/kcron.png
%{tde_tdedocdir}/HTML/en/kcron/
@@ -128,7 +169,7 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%package -n trinity-kdat
Summary: A Trinity tape backup tool
-Group: Applications/Utilities
+Group: System/GUI/Other
%description -n trinity-kdat
KDat is a tar-based tape archiver. It is designed to work with multiple
@@ -169,10 +210,11 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%package kfile-plugins
Summary: Trinity file metainfo plugins for deb and rpm files
-Group: Environment/Libraries
+Group: System/GUI/Other
%description kfile-plugins
-File metainfo plugins for deb and rpm package files.
+This package contains the Trinity File metainfo plugins for deb and rpm
+package files.
%files kfile-plugins
%defattr(-,root,root,-)
@@ -187,7 +229,7 @@ File metainfo plugins for deb and rpm package files.
%package -n trinity-knetworkconf
Summary: Trinity network configuration tool
-Group: Applications/Utilities
+Group: System/GUI/Other
%description -n trinity-knetworkconf
This is a TDE control center module to configure TCP/IP settings. It
@@ -223,7 +265,7 @@ done
%package -n trinity-kpackage
Summary: Trinity package management tool
-Group: Applications/Utilities
+Group: System/GUI/Other
%description -n trinity-kpackage
This is a frontend to both .rpm and .deb package formats. It allows you
@@ -258,7 +300,7 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%package -n trinity-ksysv
Summary: Trinity SysV-style init configuration editor
-Group: Applications/Utilities
+Group: System/GUI/Other
%description -n trinity-ksysv
This program allows you to edit your start and stop scripts using a
@@ -295,7 +337,7 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%package -n trinity-kuser
Summary: Trinity user/group administration tool
-Group: Applications/Utilities
+Group: System/GUI/Other
%if 0%{?with_consolehelper}
# package 'usermode' provides '/usr/bin/consolehelper-gtk'
@@ -347,7 +389,7 @@ update-desktop-database %{tde_datadir}/applications > /dev/null 2>&1 || :
%if 0%{?with_lilo}
%package -n trinity-lilo-config
Summary: Trinity frontend for lilo configuration
-Group: Applications/Utilities
+Group: System/GUI/Other
Requires: trinity-kcontrol
Requires: trinity-tdebase-bin
#Requires: lilo
@@ -372,7 +414,7 @@ touch /etc/lilo.conf
##########
-%if 0%{?suse_version} || 0%{?pclinuxos}
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
@@ -468,6 +510,26 @@ done
# * Removed useless program secpolicy. (Closes: #399426)
%__rm -f %{?buildroot}%{tde_bindir}/secpolicy
+# Remove lilo related files, if unwanted.
+%if 0%{?with_lilo} == 0
+%__rm -rf %{?buildroot}%{tde_tdedocdir}/HTML/en/lilo-config/
+%__rm -f %{?buildroot}%{tde_tdelibdir}/kcm_lilo.la
+%__rm -f %{?buildroot}%{tde_tdelibdir}/kcm_lilo.so
+%__rm -f %{?buildroot}%{tde_tdeappdir}/lilo.desktop
+%endif
+
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file kdat System Backup
+%suse_update_desktop_file kpackage System PackageManager
+%suse_update_desktop_file kcron System ServiceConfiguration
+%suse_update_desktop_file ksysv System ServiceConfiguration
+%suse_update_desktop_file kuser System SystemSetup
+%endif
+
+# Links duplicate files
+%fdupes "%{?buildroot}%{tde_datadir}"
+
%clean
%__rm -rf %{buildroot}