summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdebase/tdebase-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdebase/tdebase-14.0.0.spec')
-rw-r--r--redhat/main/tdebase/tdebase-14.0.0.spec27
1 files changed, 27 insertions, 0 deletions
diff --git a/redhat/main/tdebase/tdebase-14.0.0.spec b/redhat/main/tdebase/tdebase-14.0.0.spec
index 2003bcf57..bc3c29666 100644
--- a/redhat/main/tdebase/tdebase-14.0.0.spec
+++ b/redhat/main/tdebase/tdebase-14.0.0.spec
@@ -224,6 +224,14 @@ Requires: fedora-logos
%define tde_starticon /usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
%endif
+# Fedora 28 Theme
+%if 0%{?fedora} == 28
+Requires: f28-backgrounds-base
+%define tde_bg /usr/share/backgrounds/f27/default/standard/f28.png
+Requires: fedora-logos
+%define tde_starticon /usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
+%endif
+
# RHEL 4 Theme
%if 0%{?rhel} == 4
Requires: desktop-backgrounds-basic
@@ -363,6 +371,14 @@ Requires: hicolor-icon-theme-branding
%define tde_starticon /usr/share/icons/hicolor/scalable/apps/distributor.svg
%endif
+# OpenSuse 15.0 Theme
+%if "%{?suse_version}" == "1500"
+Requires: wallpaper-branding
+%define tde_bg /usr/share/wallpapers/openSUSEdefault/contents/images/1600x1200.jpg
+Requires: hicolor-icon-theme-branding
+%define tde_starticon /usr/share/icons/hicolor/scalable/apps/distributor.svg
+%endif
+
BuildRequires: trinity-arts-devel >= %{tde_epoch}:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
@@ -683,6 +699,12 @@ BuildRequires: libconfig-devel
BuildRequires: libr-devel >= 0.6.0
%endif
+# RPC support
+%if 0%{?fedora} >= 28
+BuildRequires: libtirpc-devel
+BuildRequires: rpcgen
+%endif
+
# tdebase is a metapackage that installs all sub-packages
Requires: %{name}-runtime-data-common = %{version}-%{release}
Requires: %{name}-data = %{version}-%{release}
@@ -3280,6 +3302,11 @@ if [ -d "/usr/include/openldap24" ]; then
RPM_OPT_FLAGS="-I%{_includedir}/openldap24 -L%{_libdir}/openldap24 ${RPM_OPT_FLAGS}"
fi
+# libtirpc (fedora)
+if [ -d "/usr/include/tirpc" ]; then
+ RPM_OPT_FLAGS="$(pkg-config --cflags --libs libtirpc) ${RPM_OPT_FLAGS}"
+fi
+
if ! rpm -E %%cmake|grep -q "cd build"; then
%__mkdir_p build
cd build