summaryrefslogtreecommitdiffstats
path: root/redhat/main/tdebase/tdebase-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/main/tdebase/tdebase-14.0.0.spec')
-rw-r--r--redhat/main/tdebase/tdebase-14.0.0.spec46
1 files changed, 30 insertions, 16 deletions
diff --git a/redhat/main/tdebase/tdebase-14.0.0.spec b/redhat/main/tdebase/tdebase-14.0.0.spec
index 0b9314bd1..409761703 100644
--- a/redhat/main/tdebase/tdebase-14.0.0.spec
+++ b/redhat/main/tdebase/tdebase-14.0.0.spec
@@ -23,6 +23,7 @@
%define tde_pkg tdebase
%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
+%define tde_confdir %{_sysconfdir}/trinity
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
@@ -325,7 +326,7 @@ BuildRequires: cyrus-sasl-devel
BuildRequires: pam-devel
# LIBUSB support
-%if 0%{?mageia} || 0%{?mandriva} || 0%{?pclinuxos}
+%if 0%{?mgaversion} || 0%{?mdkversion} || 0%{?pclinuxos}
BuildRequires: %{_lib}usb1.0-devel
BuildRequires: %{_lib}usb-compat0.1-devel
%else
@@ -349,10 +350,14 @@ BuildRequires: gamin-devel
%endif
# OPENLDAP support
+%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: openldap-devel
+%endif
%if 0%{?suse_version}
BuildRequires: openldap2-devel
-%else
-BuildRequires: openldap-devel
+%endif
+%if 0%{?rhel} == 5
+BuildRequires: openldap24-libs-devel
%endif
# SENSORS support
@@ -371,6 +376,9 @@ BuildRequires: libudev-devel
%define with_tdehwlib 1
%endif
+# ACL support
+BuildRequires: libacl-devel
+
# XRANDR support
# On RHEL5, xrandr library is too old.
%if 0%{?fedora} >= 15 || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?rhel} >= 6 || 0%{?suse_version}
@@ -570,7 +578,7 @@ BuildRequires: drakconf
# LIBCONFIG support
# Needed for "compton" stuff
%if 0%{?rhel} >= 6 || 0%{?suse_version} || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?fedora}
-%define with_compton 1
+%define with_libconfig 1
BuildRequires: libconfig-devel
%endif
@@ -1295,7 +1303,7 @@ TDE applications, particularly those in the TDE base module.
%if 0%{?with_tsak}
%{tde_bindir}/tsak
%endif
-%if 0%{?with_compton}
+%if 0%{?with_libconfig}
%{tde_bindir}/compton-tde
%endif
%{tde_bindir}/tdedebugdialog
@@ -2190,7 +2198,7 @@ already. Most users won't need this.
%dir %{tdm_datadir}/sessions
%{tdm_datadir}/sessions/*.desktop
%{tdm_datadir}/themes/
-%{tde_datadir}/config/%{tdm}
+%{tde_confdir}/%{tdm}
%dir %{_sysconfdir}/trinity/%{tdm}
%config(noreplace) %{_sysconfdir}/trinity/%{tdm}/*
%{tde_tdedocdir}/HTML/en/%{tdm}/
@@ -3524,7 +3532,7 @@ fi
%__sed -i "tdeioslave/media/tdecmodule/media.desktop" -e "s|^Icon=.*|Icon=kcmmedia|"
# RHEL 5 does not support 'compton'
-%if 0%{?with_compton} == 0
+%if 0%{?with_libconfig} == 0
%__sed -i "twin/CMakeLists.txt" -e "/compton-tde/ s/^/#/"
%endif
@@ -3540,6 +3548,11 @@ if [ -d "/usr/include/samba-4.0" ]; then
export CMAKE_INCLUDE_PATH="${CMAKE_INCLUDE_PATH}:/usr/include/samba-4.0"
fi
+# openldap 2.4 includes (CentOS 5)
+if [ -d "/usr/include/openldap24" ]; then
+ RPM_OPT_FLAGS="-I%{_includedir}/openldap24 -L%{_libdir}/openldap24 ${RPM_OPT_FLAGS}"
+fi
+
if ! rpm -E %%cmake|grep -q "cd build"; then
%__mkdir_p build
cd build
@@ -3556,6 +3569,7 @@ fi
-DWITH_GCC_VISIBILITY=ON \
\
-DBIN_INSTALL_DIR="%{tde_bindir}" \
+ -DCONFIG_INSTALL_DIR="%{tde_confdir}" \
-DINCLUDE_INSTALL_DIR="%{tde_tdeincludedir}" \
-DLIB_INSTALL_DIR="%{tde_libdir}" \
-DSHARE_INSTALL_PREFIX="%{tde_datadir}" \
@@ -3573,8 +3587,8 @@ fi
-DWITH_XFIXES=ON \
%{?!with_xrandr:-DWITH_XRANDR=OFF} \
-DWITH_XRENDER=ON \
- -DWITH_XDAMAGE=ON \
- -DWITH_XEXT=ON \
+ %{?!with_libconfig:-DWITH_LIBCONFIG=OFF} \
+ -DWITH_PCRE=ON \
%{?!with_xtest:-DWITH_XTEST=OFF} \
-DWITH_OPENGL=ON \
%{?!with_xscreensaver:-DWITH_XSCREENSAVER=OFF} \
@@ -3582,6 +3596,7 @@ fi
-DWITH_LIBUSB=ON \
-DWITH_LIBRAW1394=ON \
-DWITH_SUDO_TDESU_BACKEND=OFF \
+ -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND=OFF \
-DWITH_PAM=ON \
-DWITH_SHADOW=OFF \
-DWITH_XDMCP=ON \
@@ -3591,8 +3606,8 @@ fi
-DWITH_SENSORS=ON \
%{?with_hal:-DWITH_HAL=ON} \
%{?!with_tdehwlib:-DWITH_TDEHWLIB=OFF} \
- -DWITH_ELFICON=OFF \
-DWITH_UPOWER=ON \
+ -DWITH_ELFICON=OFF \
\
-DBUILD_ALL=ON \
%if 0%{?suse_version}
@@ -3606,6 +3621,9 @@ fi
%endif
%{!?with_kbdledsync:-DBUILD_TDEKBDLEDSYNC=OFF} \
%{!?with_tsak:-DBUILD_TSAK=OFF} \
+%if 0%{?fedora} >= 22
+ -DHTDIG_SEARCH_BINARY="/usr/bin/htdig" \
+%endif
..
%__make %{?_smp_mflags} || %__make
@@ -3699,10 +3717,6 @@ fi
%__sed -i "s|kdm|tdm|g" "%{?buildroot}/usr/lib/systemd/system/tdm.service"
%endif
-# Symlink TDM configuration
-%__mkdir_p "%{?buildroot}%{tde_datadir}/config"
-%__ln_s "%{_sysconfdir}/trinity/%{tdm}" "%{?buildroot}%{tde_datadir}/config/%{tdm}"
-
# SELINUX policy for RHEL / Fedora
%if 0%{?with_selinux_policy}
%__install -D -m 644 "%{SOURCE8}" "%{?buildroot}%{?_sysconfdir}/trinity/%{tdm}/tdm.pp"
@@ -3768,8 +3782,8 @@ for i in {16,22}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i
for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/places/network.png hicolor/"$i"x"$i"/apps/kcmnetpref.png ;done
for i in {16,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/devices/blockdevice.png hicolor/"$i"x"$i"/apps/kcmkdnssd.png ;done
for i in {16,22,32,48,64}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/devices/input-joystick.png hicolor/"$i"x"$i"/apps/kcmjoystick.png ;done
-for i in {16,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/devices/mouse.png hicolor/"$i"x"$i"/apps/kcmmouse.png ;done
-for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/devices/system.png hicolor/"$i"x"$i"/apps/kcmmedia.png ;done
+for i in {16,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/devices/input-mouse.png hicolor/"$i"x"$i"/apps/kcmmouse.png ;done
+for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/devices/computer.png hicolor/"$i"x"$i"/apps/kcmmedia.png ;done
for i in {16,22,32}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/actions/encrypted.png hicolor/"$i"x"$i"/apps/kcmcrypto.png ;done
for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/places/trashcan_empty.png hicolor/"$i"x"$i"/apps/kcmprivacy.png ;done
for i in {16,22,32,48,64,128}; do %__cp %{tde_datadir}/icons/crystalsvg/"$i"x"$i"/places/network.png hicolor/"$i"x"$i"/apps/kcmnic.png ;done