summaryrefslogtreecommitdiffstats
path: root/redhat/tdeedu/tdeedu-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/tdeedu/tdeedu-14.0.0.spec')
-rw-r--r--redhat/tdeedu/tdeedu-14.0.0.spec70
1 files changed, 53 insertions, 17 deletions
diff --git a/redhat/tdeedu/tdeedu-14.0.0.spec b/redhat/tdeedu/tdeedu-14.0.0.spec
index bcb387ef5..b49f6f6d2 100644
--- a/redhat/tdeedu/tdeedu-14.0.0.spec
+++ b/redhat/tdeedu/tdeedu-14.0.0.spec
@@ -1,46 +1,82 @@
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
+#
+# spec file for package tdeedu (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# BUILD WARNING:
+# Remove qt-devel and qt3-devel and any kde*-devel on your system !
+# Having KDE libraries may cause FTBFS here !
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# TDE specific building variables
+%define tde_pkg tdeedu
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
-
+%define tde_mandir %{tde_datadir}/man
%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
+
-Name: trinity-tdeedu
+Name: trinity-%{tde_pkg}
Summary: Educational/Edutainment applications
+Group: Amusements/Games
Version: %{tde_version}
Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+URL: http://www.trinitydesktop.org/
-License: GPLv2
-Group: Amusements/Games
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
Prefix: %{tde_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+
BuildRequires: autoconf automake libtool m4
BuildRequires: desktop-file-utils
-BuildRequires: trinity-tdelibs-devel >= %{tde_version}
-BuildRequires: python-devel python
+
+# PYTHON support
+BuildRequires: python-devel
+BuildRequires: python
+BuildRequires: gcc-c++
+BuildRequires: desktop-file-utils
+
+# BOOST support
BuildRequires: boost-devel
+
+# OCAML support
%if 0%{?rhel} >= 6 || 0%{?fedora} >= 15
BuildRequires: ocaml(compiler)
%else