summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/internet/kftpgrabber/debian/rules')
-rwxr-xr-xubuntu/_base/applications/internet/kftpgrabber/debian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/internet/kftpgrabber/debian/rules b/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
new file mode 100755
index 000000000..8292bc38c
--- /dev/null
+++ b/ubuntu/_base/applications/internet/kftpgrabber/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+# Currently is not possible to build with --enable-final
+DEB_BUILD_OPTIONS += noopt
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+build/kftpgrabber-trinity::
+ /usr/bin/docbook2x-man debian/kftpgrabber.xml
+
+binary-install/kftpgrabber-trinity::
+ install -D -p -m644 debian/kftpgrabber-trinity.lintian-overrides \
+ debian/kftpgrabber-trinity/usr/share/lintian/overrides/kftpgrabber-trinity
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+
+clean::
+ rm -f kftpgrabber.1