summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kdbg/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/kdbg/debian')
-rw-r--r--ubuntu/_base/applications/kdbg/debian/cdbs/debian-tde.mk237
-rw-r--r--ubuntu/_base/applications/kdbg/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/kdbg/debian/changelog434
-rw-r--r--ubuntu/_base/applications/kdbg/debian/compat1
-rw-r--r--ubuntu/_base/applications/kdbg/debian/control36
-rw-r--r--ubuntu/_base/applications/kdbg/debian/copyright27
-rw-r--r--ubuntu/_base/applications/kdbg/debian/doc-base9
-rw-r--r--ubuntu/_base/applications/kdbg/debian/docs3
-rw-r--r--ubuntu/_base/applications/kdbg/debian/install1
-rw-r--r--ubuntu/_base/applications/kdbg/debian/menu8
-rwxr-xr-xubuntu/_base/applications/kdbg/debian/rules18
-rw-r--r--ubuntu/_base/applications/kdbg/debian/source/format1
-rw-r--r--ubuntu/_base/applications/kdbg/debian/source/options6
13 files changed, 0 insertions, 800 deletions
diff --git a/ubuntu/_base/applications/kdbg/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/kdbg/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 5b4e8bfd7..000000000
--- a/ubuntu/_base/applications/kdbg/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,237 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
- sed -e "s|.*version ||" -e "s| .*||" | \
- xargs -r dpkg --compare-versions 1.17.0 lt \
- && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-endif
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-.tdepkginfo:
- echo "# TDE package information" >.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f .tdepkginfo
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/_base/applications/kdbg/debian/cdbs/versions.pl b/ubuntu/_base/applications/kdbg/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/_base/applications/kdbg/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/kdbg/debian/changelog b/ubuntu/_base/applications/kdbg/debian/changelog
deleted file mode 100644
index 85cee798e..000000000
--- a/ubuntu/_base/applications/kdbg/debian/changelog
+++ /dev/null
@@ -1,434 +0,0 @@
-kdbg-trinity (2.2.2-1) squeeze; urgency=low
-
- * Initial Release for TDE
-
- -- Slávek Banko <slavek.banko@axis.cz> Wed, 03 Jul 2013 01:55:45 +0200
-
-kdbg (2.2.1-2) unstable; urgency=low
-
- * Redone again relibtoolization making sure it uses latest automake.
- (Closes: #577679)
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Wed, 21 Apr 2010 04:31:55 +0200
-
-kdbg (2.2.1-1) unstable; urgency=low
-
- * New upstream release.
- * Redone libtoolization.
- * Remove patch 03_fix_ftbfs, merged upstream.
- * Update Standards-Version to 3.8.4, no changes required.
- * Add ${misc:Depends} to Depends:
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Sat, 10 Apr 2010 18:39:35 +0200
-
-kdbg (2.2.0-2) unstable; urgency=low
-
- * Add patch taken from upstrem to fix FTBFS with newer glibc 2.10 and gcc 4.4.
- (Closes: #552582)
- * Minor updates in the copyright file.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Thu, 19 Nov 2009 23:06:37 +0100
-
-kdbg (2.2.0-1) unstable; urgency=low
-
- * New upstream release.
- * Redone libtoolization.
- * Update Standards-Version to 3.8.3, no changes required.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Sun, 20 Sep 2009 20:41:52 +0200
-
-kdbg (2.1.1-1) unstable; urgency=low
-
- * New upstream release:
- - Do not crash when clicking on "delete" button if not program is loaded.
- (Closes: #467243)
- * Redo patches: 02_libtool_update.diff and buildprep.
- * Update upstream's email in copyright file.
- * Update copyright years.
- * Update Section in doc-base.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Mon, 29 Dec 2008 13:24:32 +0100
-
-kdbg (2.1.0-2) unstable; urgency=low
-
- * Remove unnecesary build dependency on libqt3-compat-headers.
- (Closes: #464057)
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Thu, 07 Feb 2008 11:10:15 +0100
-
-kdbg (2.1.0-1) unstable; urgency=low
-
- * New upstream release.
- * Update Standards-Version to 3.7.3.
- * Move homepage into control field.
- * Update menu file to new policy.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Wed, 26 Dec 2007 04:52:24 +0100
-
-kdbg (2.0.5-2) unstable; urgency=low
-
- * Rewrite debian/rules. Now it can be built twice in a row.
- (Closes: #424429)
- * Dangling symlinks are not longer created. (Closes: #186169)
- * Redone relibtoolization. (Closes: #418563).
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Wed, 30 May 2007 01:13:37 +0100
-
-kdbg (2.0.5-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Tue, 19 Dec 2006 02:15:51 +0100
-
-kdbg (2.0.4-3) unstable; urgency=low
-
- * Bumped compat to 5.
- * Added space to homepage pseudo header.
-
- -- Ana Beatriz Guerrero Lopez <ana@debian.org> Sat, 28 Oct 2006 03:57:29 +0200
-
-kdbg (2.0.4-2) unstable; urgency=medium
-
- * Dropping re-libtoolizing at build time, instead updating libtool
- with a patch. (Closes: #379811).
-
- -- Ana Beatriz Guerrero Lopez <ana@ekaia.org> Sat, 29 Jul 2006 14:19:18 +0200
-
-kdbg (2.0.4-1) unstable; urgency=low
-
- * New upstream release.
- * Bumped standards-version to 3.7.2, no changes required.
- * Debugger window comes to the foreground and receives the focus, after a
- breakpoint. (Closes: #171845)
- * Added support for QString in Qt4's debug libraries. (Closes: #354373)
- * Added copyright of the debian packaging.
- * Changed kdbg webpage.
-
- -- Ana Beatriz Guerrero Lopez <ana@ekaia.org> Sat, 3 Jun 2006 13:17:46 +0200
-
-kdbg (2.0.3-3) unstable; urgency=low
-
- * Dropping patches, re-libtoolizing at build time.
-
- -- Ana Beatriz Guerrero Lopez <ana@ekaia.org> Tue, 21 Feb 2006 12:43:49 +0100
-
-kdbg (2.0.3-2) unstable; urgency=low
-
- * Added patch: 04_am_maintainer_mode.diff, the patch adds AM_MAINTAINER_MODE to
- configure.in (Closes: #349988).
-
- -- Ana Beatriz Guerrero Lopez <ana@ekaia.org> Thu, 2 Feb 2006 02:08:56 +0100
-
-kdbg (2.0.3-1) unstable; urgency=low
-
- * New upstream release.
- * Added patch: 10_update_libtool.diff, now the package doesn't depend from
- libfreetype6 and other spurious libraries.
-
- -- Ana Beatriz Guerrero Lopez <ana@ekaia.org> Tue, 24 Jan 2006 23:12:03 +0100
-
-kdbg (2.0.2-1) unstable; urgency=low
-
- * New upstream release. (Closes: #342096).
- * New maintainer's email address.
- * debian/rules: moved debhelper compatibility level setting to
- 'debian/compat'.
-
- -- Ana Beatriz Guerrero Lopez <ana@ekaia.org> Tue, 6 Dec 2005 19:07:51 +0100
-
-kdbg (2.0.0-1) unstable; urgency=low
-
- * Adopted by Ana Beatriz Guerrero Lopez <anja_isbilia@yahoo.es>.
- (Closes: #315336).
- * New upstream release.
- * Bumped standards-version to 3.6.2.
-
- -- Ana Beatriz Guerrero Lopez <anja_isbilia@yahoo.es> Tue, 30 Aug 2005 19:03:50 +0000
-
-kdbg (1.9.7-2) unstable; urgency=low
-
- * Updated config.{sub,guess} for compilation on GNU/k*BSD (closes: #305839).
-
- -- Ben Burton <bab@debian.org> Wed, 27 Apr 2005 08:11:57 +1000
-
-kdbg (1.9.7-1) unstable; urgency=low
-
- * New upstream release.
- * Suggests kxsldbg, since kdbg can now interact with xsldbg for debugging
- XSLT scripts.
- * Patched kdbg/doc/en/Makefile.am to install newer parts of the manual
- that weren't installed by default. Using AM_MAINTAINER_MODE to
- facilitate this.
-
- -- Ben Burton <bab@debian.org> Sat, 26 Mar 2005 00:24:40 +1100
-
-kdbg (1.2.10-3) unstable; urgency=low
-
- * Converted all PO-files to UTF-8 so that all characters are properly
- displayed (closes: #291317).
-
- -- Ben Burton <bab@debian.org> Tue, 8 Feb 2005 18:52:34 +1100
-
-kdbg (1.2.10-2) unstable; urgency=low
-
- * Updated debian/copyright, including more explicit copyright information
- and additional author credits.
- * Minor aesthetic update to short package description.
-
- -- Ben Burton <bab@debian.org> Wed, 26 Jan 2005 12:44:28 +1100
-
-kdbg (1.2.10-1) unstable; urgency=low
-
- * New upstream bugfix release.
-
- -- Ben Burton <bab@debian.org> Sun, 20 Jun 2004 19:04:02 +1000
-
-kdbg (1.2.9-3) unstable; urgency=low
-
- * Patched gdb output parsing so that kdbg loads executables without
- errors when using newer versions of gdb (closes: #247459).
- * Quoted more fields in debian/menu.
-
- -- Ben Burton <bab@debian.org> Sat, 8 May 2004 13:00:12 +1000
-
-kdbg (1.2.9-2) unstable; urgency=low
-
- * Built against new libXrender.
- * Bumped standards-version to 3.6.1.
-
- -- Ben Burton <bab@debian.org> Fri, 2 Jan 2004 18:13:07 +1100
-
-kdbg (1.2.9-1) unstable; urgency=low
-
- * New upstream release.
- * Tighter fix for the security issue regarding debugger commands previously
- addressed in kdbg 1.2.8-1 (CAN-2003-0644). Specifically, kdbg now tests
- for .kdbgrc file ownership. Thanks to Matt Zimmerman for his help in this
- matter.
-
- -- Ben Burton <bab@debian.org> Tue, 9 Sep 2003 16:16:07 +1000
-
-kdbg (1.2.8-3) unstable; urgency=low
-
- * Using high colour pixmap for the debian menu entry.
-
- -- Ben Burton <bab@debian.org> Wed, 27 Aug 2003 20:04:25 +1000
-
-kdbg (1.2.8-2) unstable; urgency=low
-
- * Russian translations changed from kio8-r to UTF-8, thanks to Alexander
- Kogan for the patch (closes: #137203).
-
- -- Ben Burton <bab@debian.org> Tue, 22 Jul 2003 21:34:49 +1000
-
-kdbg (1.2.8-1) unstable; urgency=low
-
- * New upstream release.
- * Security update. Fixes the security flaw regarding the program
- specific debugger command, which can lead to a potential exploit
- when debugging programs in world-writable directories such as /tmp.
- * Split menu title into title and longtitle.
- * Minor man page cleanup.
- * Bumped standards-version to 3.6.0.
-
- -- Ben Burton <bab@debian.org> Sat, 19 Jul 2003 11:32:12 +1000
-
-kdbg (1.2.7-2) unstable; urgency=low
-
- * Fresh copy of debianrules for new Qt dirs (closes: #185085).
- * Build-depends on libqt3-compat-headers.
- * Removed alpha compile flags.
-
- -- Ben Burton <bab@debian.org> Mon, 17 Mar 2003 13:38:07 +1100
-
-kdbg (1.2.7-1) unstable; urgency=low
-
- * New upstream release.
- * First KDE3 upload to debian!
-
- -- Ben Burton <bab@debian.org> Sun, 2 Feb 2003 11:19:37 +1100
-
-kdbg (1.2.6-3) unstable; urgency=low
-
- * New maintainer email address.
- * Bumped standards-version to 3.5.8.
-
- -- Ben Burton <bab@debian.org> Sun, 1 Dec 2002 15:29:49 +1100
-
-kdbg (1.2.6-2) unstable; urgency=low
-
- * Built with g++-3.2.
-
- -- Ben Burton <benb@acm.org> Tue, 5 Nov 2002 20:09:30 +1100
-
-kdbg (1.2.6-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Ben Burton <benb@acm.org> Mon, 14 Oct 2002 08:06:01 +1000
-
-kdbg (1.2.5-3) unstable; urgency=low
-
- * Fixed doc-base link.
-
- -- Ben Burton <benb@acm.org> Fri, 30 Aug 2002 17:20:28 +1000
-
-kdbg (1.2.5-2) unstable; urgency=low
-
- * Rebuilt for KDE3.
-
- -- Ben Burton <benb@acm.org> Fri, 30 Aug 2002 08:28:58 +1000
-
-kdbg (1.2.5-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Ben Burton <benb@acm.org> Wed, 10 Apr 2002 14:05:38 +1000
-
-kdbg (1.2.4-2) unstable; urgency=low
-
- * Fixed KCmdLineArgs initialisation (closes: Bug#129681).
-
- -- Ben Burton <benb@acm.org> Sun, 17 Feb 2002 19:32:01 +1100
-
-kdbg (1.2.4-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Ben Burton <benb@acm.org> Tue, 29 Jan 2002 16:17:45 +1100
-
-kdbg (1.2.3-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Ben Burton <benb@acm.org> Thu, 20 Dec 2001 20:59:34 +1000
-
-kdbg (1.2.2-6) unstable; urgency=low
-
- * Added "Debuggers" hint to debian menu entry (closes: Bug#121011).
-
- -- Ben Burton <benb@acm.org> Sat, 24 Nov 2001 19:04:06 -0600
-
-kdbg (1.2.2-5) unstable; urgency=low
-
- * Changed /usr/share/doc/kdbg/html to link to the english docs instead of
- the default language docs; this avoids installation breakage on systems
- with untranslated default languages.
-
- -- Ben Burton <benb@acm.org> Thu, 22 Nov 2001 14:00:49 -0600
-
-kdbg (1.2.2-4) unstable; urgency=low
-
- * Updated config.sub and config.guess (closes: Bug#120260).
-
- -- Ben Burton <benb@acm.org> Tue, 20 Nov 2001 01:15:36 -0600
-
-kdbg (1.2.2-3) unstable; urgency=low
-
- * No longer uses automake.
-
- -- Ben Burton <benb@acm.org> Tue, 23 Oct 2001 10:42:24 -0500
-
-kdbg (1.2.2-2) unstable; urgency=low
-
- * Updated parameters for alpha build.
-
- -- Ben Burton <benb@acm.org> Sun, 23 Sep 2001 23:07:01 -0500
-
-kdbg (1.2.2-1) unstable; urgency=low
-
- * New upstream release.
-
- -- Ben Burton <benb@acm.org> Sun, 19 Aug 2001 15:16:44 -0500
-
-kdbg (1.2.1-4) unstable; urgency=low
-
- * Fixed gcc 3.0 compile errors and added libtoolize/aclocal calls
- to debian/rules (closes: Bug#108121).
- * Cleaned up debian/rules.
-
- -- Ben Burton <benb@acm.org> Thu, 9 Aug 2001 12:00:54 +1000
-
-kdbg (1.2.1-3) unstable; urgency=low
-
- * Builds on alpha.
- * Upped standards-version to 3.5.6.
-
- -- Ben Burton <benb@acm.org> Sat, 4 Aug 2001 00:32:46 +1000
-
-kdbg (1.2.1-2) unstable; urgency=low
-
- * Removed redundancies from build-depends.
- * Cosmetic changes in debian/.
-
- -- Ben Burton <benb@acm.org> Mon, 21 May 2001 10:48:13 -0500
-
-kdbg (1.2.1-1) unstable; urgency=low
-
- * New upstream release.
- * Fleshed out man page.
- * Added automake to debian/rules configuration and removed differences
- from Makefile.in files from the debian sources.
-
- -- Ben Burton <benb@acm.org> Tue, 1 May 2001 03:00:06 -0500
-
-kdbg (1.2.0-6) unstable; urgency=low
-
- * Updated debian/rules to DH_COMPAT=3.
- * Build-Depends: required version (>> 3.0.0) of debhelper.
- * Updated Standards-Version to 3.5.2.
- * Added kderemove="1" to the debian menu item.
- * Miscellaneous tidying in debian/.
-
- -- Ben Burton <benb@acm.org> Thu, 26 Apr 2001 12:47:52 -0500
-
-kdbg (1.2.0-5) unstable; urgency=low
-
- * Fetched a newer config.sub to allow building on ARM systems
- (closes: Bug#90671).
-
- -- Ben Burton <benb@acm.org> Sun, 25 Mar 2001 16:26:40 -0600
-
-kdbg (1.2.0-4) unstable; urgency=low
-
- * Rebuilt for new libqt2 libraries.
- * Added KDbg icon to /usr/share/pixmaps and to the Debian menu item.
-
- -- Ben Burton <benb@acm.org> Tue, 6 Mar 2001 07:49:40 -0600
-
-kdbg (1.2.0-3) unstable; urgency=low
-
- * Build-Depends: Replaced kdelibs3-dev with kdelibs-dev.
-
- -- Ben Burton <benb@acm.org> Thu, 22 Feb 2001 12:12:25 -0600
-
-kdbg (1.2.0-2) unstable; urgency=low
-
- * Adopted by Ben Burton <benb@acm.org> (closes: Bug#84529).
- * Added a (fairly uninformative) man page.
- * Upgraded to Standards-Version: 3.2.1.
- * Upgraded debian/rules to DH_COMPAT=2.
- * Retitled the KDbg menu item to include the name KDbg.
- * Added a link to the KDbg User's Manual in /usr/share/doc/kdbg.
- * Miscellaneous cleanups in debian.
-
- -- Ben Burton <benb@acm.org> Sat, 17 Feb 2001 11:05:10 -0600
-
-kdbg (1.2.0-1) unstable; urgency=low
-
- * New upstream release.
- * Upload sponsored by Bradley Bell <btb@debian.org>
-
- -- Mariusz Przygodzki <dune@home.pl> Mon, 25 Dec 2000 15:51:26 +0100
-
-kdbg (1.1.7-beta1-1) unstable; urgency=low
-
- * Initial Release. Closes: #75161
- * Added kdbg.desktop
- * Upload sponsored by Bradley Bell <btb@debian.org>
-
- -- Mariusz Przygodzki <dune@home.pl> Wed, 6 Dec 2000 22:38:22 +0100
-
-Local variables:
-mode: debian-changelog
-End:
diff --git a/ubuntu/_base/applications/kdbg/debian/compat b/ubuntu/_base/applications/kdbg/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/ubuntu/_base/applications/kdbg/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/ubuntu/_base/applications/kdbg/debian/control b/ubuntu/_base/applications/kdbg/debian/control
deleted file mode 100644
index 4911d1bb4..000000000
--- a/ubuntu/_base/applications/kdbg/debian/control
+++ /dev/null
@@ -1,36 +0,0 @@
-Source: kdbg-trinity
-Section: tde
-Priority: optional
-Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-Build-Depends: debhelper (>= 9~), quilt, cdbs, cmake, tdelibs14-trinity-dev
-Standards-Version: 3.8.4
-Homepage: http://www.kdbg.org/
-
-Package: kdbg-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Recommends: gdb (>= 5.0)
-Suggests: kxsldbg-trinity
-Description: graphical debugger interface [Trinity]
- KDbg is a graphical user interface to gdb, the GNU debugger. It provides
- an intuitive interface for setting breakpoints, inspecting variables,
- stepping through code and much more. KDbg requires TDE but you can of
- course debug any program.
- .
- KDbg can also debug XSLT (XML stylesheet translation) scripts by
- interfacing with xsldbg. For this the package kxsldbg must be installed.
- .
- Features include the following:
- * Inspection of variable values in a tree structure.
- * Direct member: For certain compound data types the most important
- member values are displayed next to the variable name, so that it is
- not necessary to expand the subtree of that variable in order to see
- the member value. KDbg can also display Qt's QString values, which
- are Unicode strings.
- * Debugger at your finger tips: The basic debugger functions (step,
- next, run, finish, until, set/clear/enable/disable breakpoint) are
- bound to function keys F5 through F10. Quick and easy.
- * View source code, search text, set program arguments and environment
- variables, display arbitrary expressions.
- * Debugging of core dumps, attaching to running processes is possible.
- * Conditional breakpoints.
diff --git a/ubuntu/_base/applications/kdbg/debian/copyright b/ubuntu/_base/applications/kdbg/debian/copyright
deleted file mode 100644
index ebf1e447c..000000000
--- a/ubuntu/_base/applications/kdbg/debian/copyright
+++ /dev/null
@@ -1,27 +0,0 @@
-This package was debianized by Mariusz Przygodzki <dune@home.pl> on
-Wed, 6 Dec 2000 22:38:22 +0100.
-Maintenance was taken over by Ben Burton <bab@debian.org> on
-Sat, 17 Feb 2001 11:05:10 -0600.
-Maintenance was taken over by Ana Beatriz Guerrero López
-<ana@ekaia.org> on Tue, 30 Aug 2005 19:12:38 +0200
-
-It was downloaded from http://sourceforge.net/projects/kdbg/.
-
-Upstream Author: Johannes Sixt <j6t@kdbg.org>,
- with help from many others
-
-Copyright:
-
- © 1998-2008 Johannes Sixt <j6t@kdbg.org>
-
- You are free to distribute this software under the terms of
- the GNU General Public License.
-
-On Debian GNU/Linux systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL-2'.
-
-The Debian packaging is
- © 2000 Mariusz Przygodzki <dune@home.pl>
- © 2001-2005 Ben Burton <bab@debian.org>
- © 2005-2009 Ana Beatriz Guerrero López <ana@ekaia.org>
-and is licensed under the GPL v2, see above.
diff --git a/ubuntu/_base/applications/kdbg/debian/doc-base b/ubuntu/_base/applications/kdbg/debian/doc-base
deleted file mode 100644
index 330debeb4..000000000
--- a/ubuntu/_base/applications/kdbg/debian/doc-base
+++ /dev/null
@@ -1,9 +0,0 @@
-Document: kdbg-trinity
-Title: KDbg - User's Manual [Trinity]
-Author: Johannes Sixt <Johannes.Sixt@telecom.at>
-Abstract: KDbg is a front-end for gdb, the GNU debugger.
-Section: Programming
-
-Format: HTML
-Index: /opt/trinity/share/doc/tde/HTML/en/kdbg/index.html
-Files: /opt/trinity/share/doc/tde/HTML/en/kdbg/*.html
diff --git a/ubuntu/_base/applications/kdbg/debian/docs b/ubuntu/_base/applications/kdbg/debian/docs
deleted file mode 100644
index d5aaf5213..000000000
--- a/ubuntu/_base/applications/kdbg/debian/docs
+++ /dev/null
@@ -1,3 +0,0 @@
-BUGS
-README
-TODO
diff --git a/ubuntu/_base/applications/kdbg/debian/install b/ubuntu/_base/applications/kdbg/debian/install
deleted file mode 100644
index 0dc675f86..000000000
--- a/ubuntu/_base/applications/kdbg/debian/install
+++ /dev/null
@@ -1 +0,0 @@
-kdbg/pics/kdbg.xpm opt/trinity/share/pixmaps
diff --git a/ubuntu/_base/applications/kdbg/debian/menu b/ubuntu/_base/applications/kdbg/debian/menu
deleted file mode 100644
index 19d373c41..000000000
--- a/ubuntu/_base/applications/kdbg/debian/menu
+++ /dev/null
@@ -1,8 +0,0 @@
-?package(kdbg-trinity):\
- needs="x11"\
- section="Applications/Programming"\
- hints="TDE,Debuggers"\
- title="KDbg"\
- longtitle="KDbg (graphical debugger interface)"\
- command="/opt/trinity/bin/kdbg"\
- icon="/opt/trinity/share/pixmaps/kdbg.xpm"
diff --git a/ubuntu/_base/applications/kdbg/debian/rules b/ubuntu/_base/applications/kdbg/debian/rules
deleted file mode 100755
index 4bac98821..000000000
--- a/ubuntu/_base/applications/kdbg/debian/rules
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/kdbg/debian/source/format b/ubuntu/_base/applications/kdbg/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/_base/applications/kdbg/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/_base/applications/kdbg/debian/source/options b/ubuntu/_base/applications/kdbg/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/_base/applications/kdbg/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*