summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/multimedia/tderadio/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/multimedia/tderadio/debian')
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/debian-tde.mk251
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/changelog79
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/compat1
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/control33
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/copyright33
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/docs3
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/menu7
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/patches/series0
-rwxr-xr-xubuntu/_base/applications/multimedia/tderadio/debian/rules17
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/source/format1
-rw-r--r--ubuntu/_base/applications/multimedia/tderadio/debian/source/options6
12 files changed, 450 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/versions.pl b/ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/changelog b/ubuntu/_base/applications/multimedia/tderadio/debian/changelog
new file mode 100644
index 000000000..da92952c4
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/changelog
@@ -0,0 +1,79 @@
+tderadio-trinity (0.1.1.1~0ubuntu0) karmic; urgency=low
+
+ * Karmic upload
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sun, 22 Nov 2009 23:25:00 -0600
+
+tderadio (0.1.1.1~20061112-4) unstable; urgency=low
+
+ * QA upload ; orphaning after discussion with maintainer
+ * fix up autoconf things (Closes: 543013)
+ * Relibtoolize while we are at it.
+ * Switch to unversioned autotools.
+ * Clean up rules file.
+ * Move homepage from description to dedicated field
+ * Bump S-V
+ * Update menu file
+
+ -- Sune Vuorela <debian@pusling.com> Wed, 02 Sep 2009 00:45:55 +0200
+
+tderadio (0.1.1.1~20061112-3.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Fix gcc-4.3 FTBFS, patch by Kibi (Closes: #455390)
+
+ -- Marc 'HE' Brockschmidt <he@debian.org> Sun, 16 Mar 2008 19:00:02 +0100
+
+tderadio (0.1.1.1~20061112-3) unstable; urgency=low
+
+ * Modify build-system to use automake
+ - Remove build-depends against unsermake as it shall be removed from
+ debian soon
+ - Add build-depends against automake1.9
+ - Recreate the autofoo files
+ - Add build-depends against chrpath and use it to remove some rpaths
+ * Make sure that all the .gmo generated files are deleted to avoid
+ the FTBFS during a second build (Closes: #424463)
+ * Dependencies are accurate for the new libflac libraries
+ (Closes: #426649)
+
+ -- Steffen Joeris <white@debian.org> Wed, 20 Jun 2007 22:14:59 +0200
+
+tderadio (0.1.1.1~20061112-2) unstable; urgency=low
+
+ * Upload to unstable
+
+ -- Steffen Joeris <white@debian.org> Mon, 23 Apr 2007 05:59:03 +1000
+
+tderadio (0.1.1.1~20061112-1) experimental; urgency=low
+
+ * New upstream release
+ * Fix small typo in debian/copyright
+ * Bump debhelper level to 5
+ * Change my maintainer address
+
+ -- Steffen Joeris <white@debian.org> Sun, 7 Jan 2007 18:42:05 +0100
+
+tderadio (0.1.1.1~20060920-1) unstable; urgency=low
+
+ * New upstream version
+ * Drop 10-configure.dpatch
+ * Drop dpatch from debian/rules and debian/control
+ * Add build-depends against unsermake
+ * Adjust debian/rules for cleaning up properly
+ * Add temporary dependency, because unsermake is broken
+
+ -- Steffen Joeris <steffen.joeris@skolelinux.de> Tue, 3 Oct 2006 15:01:07 +1000
+
+tderadio (0.1beta1.0snapshot20051127-2) unstable; urgency=low
+
+ * Upload to unstable, no changes
+
+ -- Steffen Joeris <steffen.joeris@skolelinux.de> Sun, 5 Feb 2006 18:42:11 +0100
+
+tderadio (0.1beta1.0snapshot20051127-1) experimental; urgency=low
+
+ * Initial release for Debian (Closes: #341954)
+ * drop debian dir from upstream and use own debian dir
+
+ -- Steffen Joeris <steffen.joeris@skolelinux.de> Sun, 4 Dec 2005 12:01:26 +0000
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/compat b/ubuntu/_base/applications/multimedia/tderadio/debian/compat
new file mode 100644
index 000000000..f599e28b8
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/control b/ubuntu/_base/applications/multimedia/tderadio/debian/control
new file mode 100644
index 000000000..594d6c136
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/control
@@ -0,0 +1,33 @@
+Source: tderadio-trinity
+Section: sound
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev,
+ liblirc-dev, libsndfile1-dev, libmp3lame-dev, libogg-dev, libvorbis-dev
+Standards-Version: 3.8.4
+
+Package: tderadio-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: kradio-kde3 (<< 4:14.0.0~), kradio-trinity (<< 4:14.0.0~)
+Breaks: kradio-kde3 (<< 4:14.0.0~), kradio-trinity (<< 4:14.0.0~)
+Description: Comfortable Radio Application for TDE [Trinity]
+ TDERadio is a comfortable radio application for TDE with support for
+ V4L and V4L2 radio cards drivers.
+ .
+ TDERadio currently provides
+ .
+ * V4L/V4L2 radio support
+ * Remote control support (LIRC)
+ * Alarms, sleep Countdown
+ * Several GUI Controls (Docking Menu, Station Quickbar, Radio Display)
+ * Recording capabilities, including MP3 and Ogg/Vorbis encoding
+ * Timeshifter functionality
+ * Extendable plugin architecture
+ .
+ This package also includes a growing collection of station preset
+ files for many cities around the world contributed by TDERadio users.
+ .
+ As TDERadio is based on an extendable plugin architecture, contributions
+ of new plugins (e.g. Internet Radio Streams, new cool GUIs) are welcome.
+ .
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/copyright b/ubuntu/_base/applications/multimedia/tderadio/debian/copyright
new file mode 100644
index 000000000..365f66795
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/copyright
@@ -0,0 +1,33 @@
+This package was debianized by Ernst Martin Witte <emw@users.sourceforge.net> on
+Sun, 14 Sep 2003 13:31:07 +0200.
+
+It was downloaded from http://tderadio.sourceforge.net/
+
+Copyright Holder: Ernst Martin Witte, Klas Kalass (C) 2002-2003
+Additional copyright information:
+ (C) 2001, 2002 by Frank Schwanz, Ernst Martin Witte
+ schwanz@fh-brandenburg.de, witte@kawo1.rwth-aachen.de
+ (C) 2001-2005 by Ernst Martin Witte, Frank Schwanz
+ witte@kawo1.rwth-aachen.de, schwanz@fh-brandenburg.de
+ (C) 2005 by Marcus Camen
+ mcamen@mcamen.de
+
+
+ The following files have the copyright notice
+ Trolltech AS Copyright (C) 1996-1997
+tderadio3/plugins/gui-quickbar/buttonflowlayout.h
+tderadio3/plugins/gui-quickbar/buttonflowlayout.cpp
+
+License:
+
+This program is free software; you can redistribute it and/or
+modify it under the terms of the GNU General Public License, version 2
+or higher as published by the Free Software Foundation.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANDABILITY of FITNESS FOR A PARTICULAR PURPOSE.
+See the GNU General Public License for details.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/docs b/ubuntu/_base/applications/multimedia/tderadio/debian/docs
new file mode 100644
index 000000000..76c3076c9
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/docs
@@ -0,0 +1,3 @@
+AUTHORS
+README.md
+TODO
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/menu b/ubuntu/_base/applications/multimedia/tderadio/debian/menu
new file mode 100644
index 000000000..a81c3fdbd
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/menu
@@ -0,0 +1,7 @@
+?package(tderadio-trinity):needs="X11" \
+ section="Applications/TV and Radio" \
+ hints="TDE" \
+ title="TDERadio" \
+ longtitle="K-Radio Application" \
+ command="/opt/trinity/bin/tderadio" \
+ icon="/opt/trinity/share/pixmaps/tderadio.xpm"
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/patches/series b/ubuntu/_base/applications/multimedia/tderadio/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/patches/series
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/rules b/ubuntu/_base/applications/multimedia/tderadio/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/source/format b/ubuntu/_base/applications/multimedia/tderadio/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/ubuntu/_base/applications/multimedia/tderadio/debian/source/options b/ubuntu/_base/applications/multimedia/tderadio/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/_base/applications/multimedia/tderadio/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*