summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/system/katapult/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/system/katapult/debian')
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/cdbs/debian-tde.mk251
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/changelog270
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/compat1
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/control21
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/copyright35
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/docs3
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/katapult-trinity.lintian13
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/menu3
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/patches/series0
-rwxr-xr-xubuntu/_base/applications/system/katapult/debian/rules21
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/source/format1
-rw-r--r--ubuntu/_base/applications/system/katapult/debian/source/options6
13 files changed, 644 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/system/katapult/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/system/katapult/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/_base/applications/system/katapult/debian/cdbs/versions.pl b/ubuntu/_base/applications/system/katapult/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/system/katapult/debian/changelog b/ubuntu/_base/applications/system/katapult/debian/changelog
new file mode 100644
index 000000000..4452b8a56
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/changelog
@@ -0,0 +1,270 @@
+katapult-trinity (0.3.2.1~0ubuntu3) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+katapult-trinity (0.3.2.1~0ubuntu2) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 05 March 2009 01:11:00 -0600
+
+katapult-trinity (0.3.2.1~0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 11 Dec 2008 16:43:00 -0600
+
+katapult (0.3.2.1-3) unstable; urgency=low
+
+ * Updated Slovak Translation .po (Closes: #441628)
+ * Added patch to make katapult link against QT
+ * Updated Rules for ability to build with dash (Closes: #459167)
+ * Bumped Standards Version
+ * Added Patch to fix issues with MySQL 5 BC Breaks
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 10 Mar 2008 16:41:04 +0000
+
+katapult (0.3.2.1-2) unstable; urgency=low
+
+ * Merged in ubuntu Changes (outline below)
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 23 Jul 2007 08:22:14 +0100
+
+katapult (0.3.2.1-1ubuntu2) gutsy; urgency=low
+
+ * Fix Fix ftbfs, bad version uploaded
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 19 Jul 2007 20:36:32 +0200
+
+katapult (0.3.2.1-1ubuntu1) gutsy; urgency=low
+
+ * Dont install the autostart desktop file. Causes katapult to show at
+ every boot, so well use ksmserver instead for silent startup.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 19 Jul 2007 10:23:35 +0200
+
+katapult (0.3.2.1-1) unstable; urgency=low
+
+ * New Upstream Release
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 22:12:51 +0100
+
+katapult (0.3.2.1-0ubuntu1) gutsy; urgency=low
+
+ * New Upstream Release
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 22:12:35 +0100
+
+katapult (0.3.2-1) unstable; urgency=low
+
+ * New Upstream Release
+ * Fixed Localisation Issues (Closes: #352681)
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 21:30:09 +0100
+
+katapult (0.3.2-0ubuntu1) gutsy; urgency=low
+
+ * New Upstream Release
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 21:29:57 +0100
+
+katapult (0.3.1.4-0ubuntu6) gutsy; urgency=low
+
+ * Add kubuntu_01_clean_SQL.patch
+ Fixes LP: #120575
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Fri, 29 Jun 2007 17:25:09 +0200
+
+katapult (0.3.1.4-0ubuntu5) feisty; urgency=low
+
+ * Switch back to ksmserver autostart, since/usr/bin/autostart
+ let katapult appear on screen at every boot.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 20 Jan 2007 08:42:27 +0100
+
+katapult (0.3.1.4-0ubuntu4) feisty; urgency=low
+
+ * Changed debian/rules, install autostart file in
+ /usr/share/autostart
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 20 Jan 2007 01:27:32 +0100
+
+katapult (0.3.1.4-0ubuntu3) feisty; urgency=low
+
+ * debian/control: Update upstream URL.
+ * debian/copyright: Correct misspelling of upstream authors.
+
+ -- Daniel T Chen <crimsun@ubuntu.com> Mon, 15 Jan 2007 12:54:56 -0500
+
+katapult (0.3.1.4-0ubuntu2) feisty; urgency=low
+
+ * Fixed source package diff.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 7 Nov 2006 10:39:26 -0800
+
+katapult (0.3.1.4-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+ * Removed all obsolete patches
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 6 Nov 2006 14:06:26 -0800
+
+katapult (0.3.1.3-0ubuntu5) edgy; urgency=low
+
+ * Add kubuntu_06_amarok_14.diff closes 60136
+ * Add kubuntu_07_work_with_non_english.diff closes 48103
+ * Add build-dep on sharutils
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sun, 22 Oct 2006 14:51:54 +0100
+
+katapult (0.3.1.3-0ubuntu4) edgy; urgency=low
+
+ * Set .pot name in debian/rules
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sun, 1 Oct 2006 13:02:12 +0100
+
+katapult (0.3.1.3-0ubuntu3) edgy; urgency=low
+
+ * Add kubuntu_05_fix_doublebackspace.diff, fixes Malone
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Wed, 27 Sep 2006 22:03:02 +0200
+
+katapult (0.3.1.3-0ubuntu2) edgy; urgency=low
+
+ * Add kubuntu_03_spellingcatalog.diff.uu and kubuntu_04_spellingcatalog_default.diff
+ to add back missing spelling catalogue
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 18 Sep 2006 13:53:26 +0100
+
+katapult (0.3.1.3-0ubuntu1) edgy; urgency=low
+
+ * New upstream release (closing #58178 and #56918)
+ * Tarball rebuilt for modern "admin" folder since buildprep is used
+ due to Makefile.am addition by patch kubuntu_01_o2display.diff and
+ current admin folder is uncompatible with autoconf 2.60
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 30 Aug 2006 13:20:02 +0200
+
+katapult (0.3.1.2svn20060711-0ubuntu2) edgy; urgency=low
+
+ * Add kubuntu_01_o2display.diff with new look by Ken Wimer
+ * Add kubuntu_02_text_colours.diff with new text colours by Ken Wimer
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 29 Aug 2006 18:26:02 +0100
+
+katapult (0.3.1.2svn20060711-0ubuntu1) edgy; urgency=low
+
+ * New snapshot
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 11 Jul 2006 15:36:09 +0000
+
+katapult (0.3.1.2-0ubuntu4) dapper; urgency=low
+
+ * Rebuild to use dh_iconcache.
+
+ -- Daniel Holbach <daniel.holbach@ubuntu.com> Thu, 18 May 2006 15:08:05 +0200
+
+katapult (0.3.1.2-0ubuntu3) dapper; urgency=low
+
+ [ Martin Meredith ]
+ * Add patch kubuntu_01_amarok_mysql.diff
+ allows Amarok plugin to work when Amarok is using mysql
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sat, 13 May 2006 13:25:57 +0300
+
+katapult (0.3.1.2-0ubuntu2) dapper; urgency=low
+
+ * Updated Control to list correct homepage
+
+ -- Martin Meredith <mez@ubuntu.com> Fri, 10 Mar 2006 13:45:03 +0000
+
+katapult (0.3.1.2-0ubuntu1) dapper; urgency=low
+
+ * New Upstream Version
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 6 Mar 2006 19:37:07 +0000
+
+katapult (0.3.1.1-1) unstable; urgency=low
+
+ * New Upstream Version
+ * Removed patches - incorporated into upstream
+
+ -- Martin Meredith <mez@ubuntu.com> Fri, 10 Mar 2006 13:43:49 +0000
+
+katapult (0.3.1-1) unstable; urgency=low
+
+ * Initial upload to Debian. (Closes: #344787: ITP: katapult -- KDE Launcher
+ Application - Debian Bug report logs)
+
+ -- Martin Meredith <mez@ubuntu.com> Tue, 17 Jan 2006 15:59:50 +0000
+
+katapult (0.3.baz20051226-1) unstable; urgency=low
+
+ * Removed automake/autotools B-D - not needed
+ * removed /doc folder - not needed
+ * Removed patchutils references - no patches - incorporated into upstream
+
+ -- Martin Meredith <mez@ubuntu.com> Wed, 28 Dec 2005 15:57:17 +0000
+
+katapult (0.3.baz20051226-0ubuntu1) dapper; urgency=low
+
+ * Updated Source to Latest Baz Branch
+ * Incorporated patches into katapult
+ * Changed Maintainer: Field in control
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 26 Dec 2005 06:16:32 +0000
+
+katapult (0.3-0ubuntu3) dapper; urgency=low
+
+ * Add back updated kubuntu_02_fix_desktop_file.diff to
+ make it not show in menu
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 15 Dec 2005 19:55:46 +0000
+
+katapult (0.3-0ubuntu2) dapper; urgency=low
+
+ * Add automake1.9 to build-dep
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Fri, 9 Dec 2005 00:02:28 +0000
+
+katapult (0.3-0ubuntu1) dapper; urgency=low
+
+ * New Upstream Version
+ * Removed all patches - In upstream
+ * Added Calculator and Amarok Plugins
+ * Add kubuntu_01_kdepot.diff for .pot generation
+ * Add kubuntu_02_default_catalogues.diff turn on calculator
+ and amarok plugins by default
+ * Add kubuntu_03_icon.diff use k-menu icon
+ * Sponsored upload for Martin Meredith <mez@ubuntu.com>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 8 Dec 2005 17:58:36 +0000
+
+katapult (0.2-0ubuntu3) breezy; urgency=low
+
+ * Add fixes from SVN:
+ - kubuntu_03_crash.diff prevent crash when it can't find an item
+ - kubuntu_04_systray_optional.diff turn off systray icon
+ - kubuntu_05_configure_shortcut.diff add keyboard shortcut for configure
+ - kubuntu_06_noautoexec.diff don't automatically start an item
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 15 Sep 2005 18:27:05 +0100
+
+katapult (0.2-0ubuntu2) breezy; urgency=low
+
+ * Add libxi-dev build-depend
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 11 Jul 2005 09:21:12 +0000
+
+katapult (0.2-0ubuntu1) breezy; urgency=low
+
+ * Initial Release.
+ * Fixed katapult.desktop file to be KDE standard complient (patch number 02).
+ * Fixed katapult/Makefile.am for desktop file directory (patch number 01).
+ * Added a manpage (from docbook source).
+ * Sponsored upload for Jean-Remy Falleri <jr.falleri@laposte.net>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 7 Jul 2005 16:00:00 +0000
diff --git a/ubuntu/_base/applications/system/katapult/debian/compat b/ubuntu/_base/applications/system/katapult/debian/compat
new file mode 100644
index 000000000..f599e28b8
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/ubuntu/_base/applications/system/katapult/debian/control b/ubuntu/_base/applications/system/katapult/debian/control
new file mode 100644
index 000000000..e36558fc3
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/control
@@ -0,0 +1,21 @@
+Source: katapult-trinity
+Section: tde
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev, libxi-dev
+Standards-Version: 3.8.4
+
+Package: katapult-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Replaces: katapult-kde3 (<< 4:14.0.0~), katapult-trinity (<< 4:14.0.0~)
+Breaks: katapult-kde3 (<< 4:14.0.0~), katapult-trinity (<< 4:14.0.0~)
+Description: item launcher for TDE [Trinity]
+ Katapult is an application, which analyses text-based queries
+ to launch items, such as bookmarks, directories or programs.
+ .
+ The application is currently in an early stage of development but
+ the launchable item list can be extended by a plugin system, and
+ the look and feel can be skinned.
+ .
+ Homepage: http://katapult.kde.org/
diff --git a/ubuntu/_base/applications/system/katapult/debian/copyright b/ubuntu/_base/applications/system/katapult/debian/copyright
new file mode 100644
index 000000000..fa75bbec3
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/copyright
@@ -0,0 +1,35 @@
+This package was debianized by Jean-Remy Falleri <jr.falleri@laposte.net> on
+Mon, 9 May 2005 17:41:21 +0200.
+
+It was downloaded from: http://sourceforge.net/projects/katapult/
+
+Upstream Authors:
+ Martin Meredith <martin@sourceguru.net>
+ Bastian Holst <bastianholst@gmx.de>
+ Tobi Vollebregt <tobivollebregt@gmail.com>
+ Lee Olson <clearbeast@gmail.com>
+ Jean-Remi Falleri <jr.falleri@gmail.com>
+ Johnathan Riddell <jriddell@ubuntu.com>
+ Joe Ferris <jferris@optimistictech.com>
+
+Copyright: (c) 2005-2007 Martin Meredith, Bastian Holst, Tobi Vollebregt,
+ Lee Olson, Jean-Remi Falleri, Jonathan Riddell,
+ and Joe Ferris
+
+Packaging: (c) 2005-2007 Martin Meredith, Jean-Remy
+
+
+All the software & packaging is GPL:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/ubuntu/_base/applications/system/katapult/debian/docs b/ubuntu/_base/applications/system/katapult/debian/docs
new file mode 100644
index 000000000..a2b373b4d
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/docs
@@ -0,0 +1,3 @@
+AUTHORS
+README.md
+
diff --git a/ubuntu/_base/applications/system/katapult/debian/katapult-trinity.lintian b/ubuntu/_base/applications/system/katapult/debian/katapult-trinity.lintian
new file mode 100644
index 000000000..d7fcffa7b
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/katapult-trinity.lintian
@@ -0,0 +1,13 @@
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_amarokcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_bookmarkcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_calculatorcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_documentcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_execcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_glassdisplay.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_googlecatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_o2display.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_programcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_puredisplay.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/services/katapult_spellcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/servicetypes/katapultdisplay.desktop
+katapult-trinity: desktop-file-in-wrong-dir opt/trinity/share/servicetypes/katapultcatalog.desktop
diff --git a/ubuntu/_base/applications/system/katapult/debian/menu b/ubuntu/_base/applications/system/katapult/debian/menu
new file mode 100644
index 000000000..fcf7c082f
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/menu
@@ -0,0 +1,3 @@
+?package(katapult-trinity):needs="X11" section="Apps/Tools"\
+ title="Katapult" command="/opt/trinity/bin/katapult"
+
diff --git a/ubuntu/_base/applications/system/katapult/debian/patches/series b/ubuntu/_base/applications/system/katapult/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/patches/series
diff --git a/ubuntu/_base/applications/system/katapult/debian/rules b/ubuntu/_base/applications/system/katapult/debian/rules
new file mode 100755
index 000000000..74e4fb499
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
+
+install/katapult-trinity::
+ rm -f $(CURDIR)/debian/$(cdbs_curpkg)/opt/trinity/lib/libkatapult*.so
+ rm -f $(CURDIR)/debian/$(cdbs_curpkg)/opt/trinity/lib/libkatapult*.la
diff --git a/ubuntu/_base/applications/system/katapult/debian/source/format b/ubuntu/_base/applications/system/katapult/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/ubuntu/_base/applications/system/katapult/debian/source/options b/ubuntu/_base/applications/system/katapult/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/_base/applications/system/katapult/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*