summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tde-systemsettings/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/applications/tde-systemsettings/debian')
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/cdbs/debian-tde.mk237
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/changelog257
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/compat1
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/control15
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/copyright36
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/docs4
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/patches/series0
-rwxr-xr-xubuntu/_base/applications/tde-systemsettings/debian/rules17
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/source/format1
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/source/options6
-rw-r--r--ubuntu/_base/applications/tde-systemsettings/debian/tde-systemsettings-trinity.preinst29
12 files changed, 0 insertions, 622 deletions
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/tde-systemsettings/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 5b4e8bfd7..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,237 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
- sed -e "s|.*version ||" -e "s| .*||" | \
- xargs -r dpkg --compare-versions 1.17.0 lt \
- && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-endif
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-.tdepkginfo:
- echo "# TDE package information" >.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f .tdepkginfo
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/cdbs/versions.pl b/ubuntu/_base/applications/tde-systemsettings/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/changelog b/ubuntu/_base/applications/tde-systemsettings/debian/changelog
deleted file mode 100644
index 244389e07..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/changelog
+++ /dev/null
@@ -1,257 +0,0 @@
-tde-systemsettings-trinity (0.0svn20070312-0ubuntu5) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
-
-tde-systemsettings-trinity (0.0svn20070312-0ubuntu4) intrepid; urgency=low
-
- * Removed long-broken Bluetooth configuration icon
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 22 April 2009 20:44:00 -0600
-
-tde-systemsettings-trinity (0.0svn20070312-0ubuntu3) intrepid; urgency=low
-
- * Moved Trinity to /opt/trinity
- * Integrated properly with KDE4.2+
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 05 March 2009 01:11:00 -0600
-
-tde-systemsettings-trinity (0.0svn20070312-0ubuntu2) intrepid; urgency=low
-
- * Added -trinity suffix
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 03 Dec 2008 18:44:00 -0600
-
-tde-systemsettings (0.0svn20070312-0ubuntu5) hardy; urgency=low
-
- * Cleanup previous installed
- /etc/xdg/menus/kde-applications-merged/system-settings-merge.menu
- (LP: #127722)
- * Add link for file association handling to system settings (LP: #50320)
- - Added debian/patches/kubuntu_05_add_filetypes_submenu.diff:
- - Patch from Slammer
- * Fix "Settings Menu cannot launch default applications module"
- - LP: #132688
- - Patch from Marcus Harris
- * Fix lintian warnings in debian/control:
- - Standards-Version: 3.7.3
- - Remove build-essential from Build-Depends
-
- -- dAniel hAhler <ubuntu@thequod.de> Sat, 29 Dec 2007 12:23:42 +0100
-
-tde-systemsettings (0.0svn20070312-0ubuntu4) gutsy; urgency=low
-
- * Added kubuntu_04_fix_share_submenu.diff, adds missing 'Desktop
- Share' entry
-
- -- Anthony Mercatante <tonio@ubuntu.com> Mon, 15 Oct 2007 11:59:04 +0200
-
-tde-systemsettings (0.0svn20070312-0ubuntu3) gutsy; urgency=low
-
- * Added kubuntu_02_checkadmin_fix.diff, fixes the way systemsettings
- checks if kcm module requires admin privileges, to make it to work
- the way kcontrol does.
-
- -- Anthony Mercatante <tonio@ubuntu.com> Wed, 22 Aug 2007 13:02:07 +0200
-
-tde-systemsettings (0.0svn20070312-0ubuntu2) gutsy; urgency=low
-
- * Use applications-merged not kde-applications-merged, XDG prefix
- not used for merge directories, closes
- https://bugs.launchpad.net/ubuntu/gutsy/+source/tde-systemsettings/+bug/114286
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 05 Jun 2007 01:57:42 +0100
-
-tde-systemsettings (0.0svn20070312-0ubuntu1) feisty; urgency=low
-
- * New snapshot
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 12 Mar 2007 23:25:11 +0000
-
-tde-systemsettings (0.0svn20070104-0ubuntu3) feisty; urgency=low
-
- * Added kubuntu_05_more_categories.diff to allow universe
- apps with kcm to go in the right section
-
- -- Anthony Mercatante <tonio@ubuntu.com> Mon, 22 Jan 2007 18:56:37 +0100
-
-tde-systemsettings (0.0svn20070104-0ubuntu2) feisty; urgency=low
-
- * Added kubuntu_04_kcmgtk to get gtk-qt-engines in the
- Appearance section
-
- -- Anthony Mercatante <tonio@ubuntu.com> Fri, 19 Jan 2007 05:42:21 +0100
-
-tde-systemsettings (0.0svn20070104-0ubuntu1) feisty; urgency=low
-
- * New SVN snapshot
- * Don't build with unsermake
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 4 Jan 2007 19:51:18 +0000
-
-tde-systemsettings (0.0svn20060929-0ubuntu1) edgy; urgency=low
-
- * New SVN snapshot
-
- -- Anthony Mercatante <tonio@ubuntu.com> Fri, 29 Sep 2006 00:02:55 +0200
-
-tde-systemsettings (0.0svn20060908-0ubuntu1) edgy; urgency=low
-
- * New SVN snapshot
-
- -- Anthony Mercatante <tonio@ubuntu.com> Fri, 8 Sep 2006 20:41:55 +0200
-
-tde-systemsettings (0.0svn20060906-0ubuntu1) edgy; urgency=low
-
- * New SVN snapshot
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 6 Sep 2006 20:51:55 +0000
-
-tde-systemsettings (0.0svn20060830-0ubuntu3) edgy; urgency=low
-
- * Changed debian/rules to remove laptoppowermanagement.desktop
-
- -- Anthony Mercatante <tonio@ubuntu.com> Tue, 5 Sep 2006 21:17:25 +0200
-
-tde-systemsettings (0.0svn20060830-0ubuntu2) edgy; urgency=low
-
- * Changed debian/rules to install kde-settings-accessibility_ss.directory
- correctly
-
- -- Anthony Mercatante <tonio@ubuntu.com> Tue, 5 Sep 2006 21:03:25 +0200
-
-tde-systemsettings (0.0svn20060830-0ubuntu1) edgy; urgency=low
-
- * New SVN snapshot, includes changes for
- kubuntu-system-settings-usability by Simon Edwards
-
- -- Anthony Mercatante <tonio@ubuntu.com> Wed, 30 Aug 2006 16:03:25 +0200
-
-tde-systemsettings (0.0svn20060803-0ubuntu2) edgy; urgency=low
-
- * Stopped tde-systemsettings installing
- kde-settings-accessibility.directory (also in tdebase-data).
- Closes bug #55135
-
- -- Sarah Hobbs <hobbsee@ubuntu.com> Fri, 4 Aug 2006 13:01:09 +1000
-
-tde-systemsettings (0.0svn20060803-0ubuntu1) edgy; urgency=low
-
- * New SVN snapshot, includes changes for
- kubuntu-system-settings-usability by Simon Edwards
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 3 Aug 2006 16:44:25 +0100
-
-tde-systemsettings (0.0svn20060512-0ubuntu1) dapper; urgency=low
-
- [ Jonathan Riddell ]
- * New SVN snapshot, includes our Debian patches now
- upstream plus new translations
-
- [ Anthony Mercatante ]
- * Move componentchooser to components
- * Show spellchecking
- * Move kcmsmserver to components
- * Move Accessibility to Personal
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Fri, 12 May 2006 16:10:16 +0300
-
-tde-systemsettings (0.0svn20060502-0ubuntu1) dapper; urgency=low
-
- [ Jonathan Riddell ]
- * New SVN snapshot
- * Adds languages cs, ka, lt
- * Bump standards-version to 3.6.2
-
- [ Simon Edwards ]
- * Support the "Close" button for modules that want it,
- closes Malone #38582
- * Disable and enable the Reset button properly.
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 2 May 2006 02:14:19 +0100
-
-tde-systemsettings (0.0svn20060413-0ubuntu1) dapper; urgency=low
-
- * New SVN snapshot, no code changes only new translations
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 13 Apr 2006 17:31:56 +0100
-
-tde-systemsettings (0.0svn20060314-0ubuntu4) dapper; urgency=low
-
- * Fix format in kubuntu_02_update_menus.diff.
-
- -- Raphaël Pinson <raphink@ubuntu.com> Fri, 17 Mar 2006 16:48:12 +0100
-
-tde-systemsettings (0.0svn20060314-0ubuntu3) dapper; urgency=low
-
- * Modify kubuntu_02_update_menus.diff to prevent k3bsetup from showing up.
-
- -- Raphaël Pinson <raphink@ubuntu.com> Fri, 17 Mar 2006 15:02:49 +0100
-
-tde-systemsettings (0.0svn20060314-0ubuntu2) dapper; urgency=low
-
- * Add kubuntu_03_no_tdebuildsycoca.diff, stop it running kbuildsycocoa
- during 'make install'
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 15 Mar 2006 01:12:43 +0000
-
-tde-systemsettings (0.0svn20060314-0ubuntu1) dapper; urgency=low
-
- * New upstream snapshot, adds various bugfixes by Simon Edwards
- - Remove text for the "reset" button and put the icon text
- of the right hand side.
- - Fix when going from a module back to the module overview, the
- last selected module icon would stay selected
- - If the dialog contents don't fit then scrollbars are shown
- - Fix the evil "This module is already loaded in systemsettings"
- error.
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 14 Mar 2006 00:44:10 +0000
-
-tde-systemsettings (0.0svn20051207-0ubuntu4) dapper; urgency=low
-
- * Don't use DEB_AUTO_UPDATE_DEBIAN_CONTROL
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 8 Dec 2005 18:52:52 +0000
-
-tde-systemsettings (0.0svn20051207-0ubuntu3) dapper; urgency=low
-
- * Add build-dep on automake1.9
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 8 Dec 2005 03:55:12 +0000
-
-tde-systemsettings (0.0svn20051207-0ubuntu2) dapper; urgency=low
-
- * Add build-dep on autoconf
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 7 Dec 2005 18:26:47 +0000
-
-tde-systemsettings (0.0svn20051207-0ubuntu1) dapper; urgency=low
-
- * New snapshot
- * Rebuild for libstdc++ transition
- * Add kubuntu_01_kdepot.diff to be able to generate .pot file
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 7 Dec 2005 16:20:32 +0000
-
-tde-systemsettings (0.0svn20050613-0ubuntu3) breezy; urgency=low
-
- * Add kubuntu_02_update_menus.diff, kde-settings-bluetooth.directory
- and kde-settings-laptops.directory to tidy up menus
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Sat, 24 Sep 2005 18:11:08 +0100
-
-tde-systemsettings (0.0svn20050613-0ubuntu2) breezy; urgency=low
-
- * Add kubuntu_01_only_show_in_kde.diff
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 20 Jun 2005 17:10:56 +0000
-
-tde-systemsettings (0.0svn20050613-0ubuntu1) breezy; urgency=low
-
- * Initial Release.
- * Added manpage (from docbook source).
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 9 Jun 2005 13:04:26 +0000
-
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/compat b/ubuntu/_base/applications/tde-systemsettings/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/control b/ubuntu/_base/applications/tde-systemsettings/debian/control
deleted file mode 100644
index db88db49c..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/control
+++ /dev/null
@@ -1,15 +0,0 @@
-Source: tde-systemsettings-trinity
-Section: tde
-Priority: optional
-Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake, tdelibs14-trinity-dev
-Standards-Version: 3.8.4
-
-Package: tde-systemsettings-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, kcontrol-trinity
-Replaces: kde-systemsettings-kde3 (<< 4:14.0.0~), kde-systemsettings-trinity (<< 4:14.0.0~)
-Breaks: kde-systemsettings-kde3 (<< 4:14.0.0~), kde-systemsettings-trinity (<< 4:14.0.0~)
-Description: easy to use control centre for TDE
- System preferences is a replacement for the TDE
- Control Centre with an improved user interface.
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/copyright b/ubuntu/_base/applications/tde-systemsettings/debian/copyright
deleted file mode 100644
index 04a4bdce1..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/copyright
+++ /dev/null
@@ -1,36 +0,0 @@
-This package was debianised by Jonathan Riddell <jriddell@ubuntu.com> on
-Thu, 9 Jun 2005 13:04:26 +0000.
-
-Debian packagers:
- Copyright (C) 2005 Jonathan Riddell <jriddell@ubuntu.com>
-
-Upstream Author:
- Benjamin Charles Meyer <ben+kubuntusystempreferences@meyerhome.net>
-
-Copyright and license:
-
-All the software and systemsettings.1.docbook is GPL:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- On Debian GNU/Linux systems, the complete text of the GNU General
- Public License can be found in `/usr/share/common-licenses/GPL'.
-
-Copyright
-
-all the software:
-
- Copyright (C) 2005 by Benjamin Charles Meyer <ben+kubuntusystempreferences@meyerhome.net>
-
-debian/systemsettings.1.docbook :
-
- Copyright (C) 2005 by Jonathan Riddell <jriddell@ubuntu.com>
-
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/docs b/ubuntu/_base/applications/tde-systemsettings/debian/docs
deleted file mode 100644
index 0eb1e7d11..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/docs
+++ /dev/null
@@ -1,4 +0,0 @@
-AUTHOR
-
-
-
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/patches/series b/ubuntu/_base/applications/tde-systemsettings/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/patches/series
+++ /dev/null
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/rules b/ubuntu/_base/applications/tde-systemsettings/debian/rules
deleted file mode 100755
index a6797f19a..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/rules
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/source/format b/ubuntu/_base/applications/tde-systemsettings/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/source/options b/ubuntu/_base/applications/tde-systemsettings/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*
diff --git a/ubuntu/_base/applications/tde-systemsettings/debian/tde-systemsettings-trinity.preinst b/ubuntu/_base/applications/tde-systemsettings/debian/tde-systemsettings-trinity.preinst
deleted file mode 100644
index f7b840ea2..000000000
--- a/ubuntu/_base/applications/tde-systemsettings/debian/tde-systemsettings-trinity.preinst
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh -e
-
-case "$1" in
-
- upgrade)
-
- # Remove wrong previous used file/dir:
- FILE="/etc/xdg/menus/kde-applications-merged/system-settings-merge.menu"
- SUBDIR="/etc/xdg/menus/kde-applications-merged"
- if [ ! -L "$SUBDIR" ] && [ -d "$SUBDIR" ]; then
- if [ -f "$FILE" ]; then rm -f "$FILE"; fi
- rmdir --ignore-fail-on-non-empty "$SUBDIR"
- fi
- ;;
-
- install|abort-upgrade)
- ;;
-
- *)
- echo "preinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-
-esac
-
-#DEBHELPER#
-
-exit 0
-