summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdeutils/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/core/tdeutils/debian')
-rw-r--r--ubuntu/_base/core/tdeutils/debian/cdbs/debian-tde.mk10
-rwxr-xr-xubuntu/_base/core/tdeutils/debian/rules12
2 files changed, 10 insertions, 12 deletions
diff --git a/ubuntu/_base/core/tdeutils/debian/cdbs/debian-tde.mk b/ubuntu/_base/core/tdeutils/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/ubuntu/_base/core/tdeutils/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/core/tdeutils/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/ubuntu/_base/core/tdeutils/debian/rules b/ubuntu/_base/core/tdeutils/debian/rules
index 413d87ff6..6014293b3 100755
--- a/ubuntu/_base/core/tdeutils/debian/rules
+++ b/ubuntu/_base/core/tdeutils/debian/rules
@@ -4,19 +4,10 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
DEB_KDE_APIDOX := yes
DEB_INSTALL_CHANGELOGS_tdefilereplace-trinity := tdefilereplace/ChangeLog
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
@@ -41,9 +32,6 @@ DOC_HTML_PRUNE := kcontrol-trinity ktimer-trinity kcharselect-trinity ksim-trini
DEB_DH_STRIP_ARGS := --exclude=examples --dbg-package=tdeutils-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
PACKAGES_WITH_LIBS := khexedit-trinity klaptopdaemon-trinity kmilo-trinity kregexpeditor-trinity ksim-trinity
#shlibs_ver = 4:3.5.0-1