summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdewebdev/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/core/tdewebdev/debian')
-rw-r--r--ubuntu/_base/core/tdewebdev/debian/cdbs/debian-tde.mk18
-rw-r--r--ubuntu/_base/core/tdewebdev/debian/compat2
-rw-r--r--ubuntu/_base/core/tdewebdev/debian/control2
-rw-r--r--ubuntu/_base/core/tdewebdev/debian/patches/common/README14
-rw-r--r--ubuntu/_base/core/tdewebdev/debian/patches/common/kubuntu_01_kdepot.diff26
-rw-r--r--ubuntu/_base/core/tdewebdev/debian/patches/series1
6 files changed, 18 insertions, 45 deletions
diff --git a/ubuntu/_base/core/tdewebdev/debian/cdbs/debian-tde.mk b/ubuntu/_base/core/tdewebdev/debian/cdbs/debian-tde.mk
index 5b4e8bfd7..aba508624 100644
--- a/ubuntu/_base/core/tdewebdev/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/core/tdewebdev/debian/cdbs/debian-tde.mk
@@ -57,6 +57,15 @@ ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
endif
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
endif
@@ -73,7 +82,7 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
@@ -193,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
@@ -214,7 +228,7 @@ debian/stamp-kde-apidox:
common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
cleanbuilddir::
-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
diff --git a/ubuntu/_base/core/tdewebdev/debian/compat b/ubuntu/_base/core/tdewebdev/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/core/tdewebdev/debian/compat
+++ b/ubuntu/_base/core/tdewebdev/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/core/tdewebdev/debian/control b/ubuntu/_base/core/tdewebdev/debian/control
index 616f4c878..f3d95dbb4 100644
--- a/ubuntu/_base/core/tdewebdev/debian/control
+++ b/ubuntu/_base/core/tdewebdev/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Adeodato Sim <dato@net.com.org.es>, Ana Beatriz Guerrero Lopez <ana@debian.org>, Armin Berres <trigger+debian@space-based.de>, Sune Vuorela <debian@pusling.com>
-Build-Depends: cdbs (>= 0.4.39-0.1), debhelper (>= 9~), quilt, cmake, tdelibs14-trinity-dev, tqt3-doc, libreadline-dev | libreadline6-dev | libreadline5-dev, libxml2-dev, libxslt1-dev, libicu-dev, libcvsservice-trinity-dev
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev, tqt3-doc, libreadline-dev | libreadline6-dev | libreadline5-dev, libxml2-dev, libxslt1-dev, libicu-dev, libcvsservice-trinity-dev
Standards-Version: 3.8.4
Homepage: http://trinity.pearsoncomputing.net
diff --git a/ubuntu/_base/core/tdewebdev/debian/patches/common/README b/ubuntu/_base/core/tdewebdev/debian/patches/common/README
deleted file mode 100644
index 9e81cc359..000000000
--- a/ubuntu/_base/core/tdewebdev/debian/patches/common/README
+++ /dev/null
@@ -1,14 +0,0 @@
-Common patches across TDE Debian packages
-=========================================
-
- These directory should contain patches to the admin/ subdir of TDE
- modules that are meant to be applied to all packaged modules. As the
- admin/ subdir is shared across modules (and so, it's identical for all
- modules at a certain version), I think it makes sense to have these
- patches in a central location, and update them here.
-
- The script update.sh takes care of automatically updating the patches
- that update autotools and libtool. You need to pass the location of an
- admin/ directory as the first argument.
-
- -- Adeodato Simó, 2005-02-26
diff --git a/ubuntu/_base/core/tdewebdev/debian/patches/common/kubuntu_01_kdepot.diff b/ubuntu/_base/core/tdewebdev/debian/patches/common/kubuntu_01_kdepot.diff
deleted file mode 100644
index 28c95742b..000000000
--- a/ubuntu/_base/core/tdewebdev/debian/patches/common/kubuntu_01_kdepot.diff
+++ /dev/null
@@ -1,26 +0,0 @@
---- kde/admin/cvs.sh 2005-11-26 02:42:02.000000000 +0000
-+++ kde/admin/cvs.sh 2005-11-26 02:42:26.000000000 +0000
-@@ -537,6 +537,8 @@
- if test -z "$PREPARETIPS"; then PREPARETIPS=preparetips ; fi
- export EXTRACTRC PREPARETIPS
-
-+kdepotpath=/usr/include/tde/tde.pot
-+
- for subdir in $dirs; do
- test -z "$VERBOSE" || echo "Making messages in $subdir"
- (cd $subdir
-@@ -554,10 +556,10 @@
- fi
- perl -e '$mes=0; while (<STDIN>) { next if (/^(if\s|else\s|endif)/); if (/^messages:/) { $mes=1; print $_; next; } if ($mes) { if (/$\\(XGETTEXT\)/ && / -o/) { s/ -o \$\(podir\)/ _translatorinfo.cpp -o \$\(podir\)/ } print $_; } else { print $_; } }' < Makefile.am | egrep -v '^include ' > _transMakefile
-
-- kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
-- if ! test -f $kdepotpath; then
-- kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
-- fi
-+# kdepotpath=${includedir:-`tde-config --expandvars --install include`}/tde.pot
-+# if ! test -f $kdepotpath; then
-+# kdepotpath=`tde-config --expandvars --prefix`/include/tde.pot
-+# fi
-
- $MAKE -s -f _transMakefile podir=$podir EXTRACTRC="$EXTRACTRC" PREPARETIPS="$PREPARETIPS" srcdir=. \
- XGETTEXT="${XGETTEXT:-xgettext} --foreign-user -C -ci18n -ki18n -ktr2i18n -kI18N_NOOP -kI18N_NOOP2 -kaliasLocale -x $kdepotpath" messages
diff --git a/ubuntu/_base/core/tdewebdev/debian/patches/series b/ubuntu/_base/core/tdewebdev/debian/patches/series
index 8f8f0bd6b..e69de29bb 100644
--- a/ubuntu/_base/core/tdewebdev/debian/patches/series
+++ b/ubuntu/_base/core/tdewebdev/debian/patches/series
@@ -1 +0,0 @@
-common/kubuntu_01_kdepot.diff