summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/akode/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/akode/debian')
-rw-r--r--ubuntu/_base/dependencies/akode/debian/cdbs/debian-tde.mk18
-rw-r--r--ubuntu/_base/dependencies/akode/debian/compat2
-rw-r--r--ubuntu/_base/dependencies/akode/debian/control17
-rw-r--r--ubuntu/_base/dependencies/akode/debian/docs2
-rw-r--r--ubuntu/_base/dependencies/akode/debian/libakode2-ffmpeg.install1
-rw-r--r--ubuntu/_base/dependencies/akode/debian/patches/series1
-rwxr-xr-xubuntu/_base/dependencies/akode/debian/rules2
7 files changed, 37 insertions, 6 deletions
diff --git a/ubuntu/_base/dependencies/akode/debian/cdbs/debian-tde.mk b/ubuntu/_base/dependencies/akode/debian/cdbs/debian-tde.mk
index 5b4e8bfd7..aba508624 100644
--- a/ubuntu/_base/dependencies/akode/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/dependencies/akode/debian/cdbs/debian-tde.mk
@@ -57,6 +57,15 @@ ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
endif
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
endif
@@ -73,7 +82,7 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
@@ -193,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
@@ -214,7 +228,7 @@ debian/stamp-kde-apidox:
common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
cleanbuilddir::
-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
diff --git a/ubuntu/_base/dependencies/akode/debian/compat b/ubuntu/_base/dependencies/akode/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/dependencies/akode/debian/compat
+++ b/ubuntu/_base/dependencies/akode/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/dependencies/akode/debian/control b/ubuntu/_base/dependencies/akode/debian/control
index c27d6439d..07f1b7913 100644
--- a/ubuntu/_base/dependencies/akode/debian/control
+++ b/ubuntu/_base/dependencies/akode/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Isaac Clerencia <isaac@debian.org>, Christopher Martin <chrsmrtn@debian.org>, Adeodato Simó <dato@net.com.org.es>
-Build-Depends: cdbs (>= 0.4.39-0.1), debhelper (>= 9~), quilt, cmake, gawk, libflac-dev (>= 1.1.1-3), libflac-dev, libmad0-dev, libogg-dev, libvorbis-dev, libasound2-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], libsamplerate0-dev, libspeex-dev, libpulse-dev, libjack-dev
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, libflac-dev (>= 1.1.1-3), libmad0-dev, libogg-dev, libvorbis-dev, libasound2-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], libsamplerate0-dev, libspeex-dev, libpulse-dev, libjack-dev, libavformat-dev
Standards-Version: 3.7.3
Package: libakode2
@@ -20,6 +20,21 @@ Description: akode plugin for aRts
FLAC and Speex. aKode also focuses on performance, and so it means a
big enhancement for users runing aRts in non-realtime mode.
+Package: libakode2-ffmpeg
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}
+Conflicts: akode
+Replaces: akode
+Enhances: libarts1c2, libarts1c2a-trinity
+Description: ffmpeg plugins for akode
+ aKode is a new multithreaded audio library that provides aRts with
+ plugins to play a variety of formats: Ogg Vorbis, Musepack (MPC),
+ FLAC and Speex. aKode also focuses on performance, and so it means a
+ big enhancement for users runing aRts in non-realtime mode.
+ .
+ This package provides for akode formats supported by FFMPEG.
+
Package: libakode2-mpeg
Section: libs
Architecture: any
diff --git a/ubuntu/_base/dependencies/akode/debian/docs b/ubuntu/_base/dependencies/akode/debian/docs
new file mode 100644
index 000000000..0b6e0f321
--- /dev/null
+++ b/ubuntu/_base/dependencies/akode/debian/docs
@@ -0,0 +1,2 @@
+AUTHORS
+README.md
diff --git a/ubuntu/_base/dependencies/akode/debian/libakode2-ffmpeg.install b/ubuntu/_base/dependencies/akode/debian/libakode2-ffmpeg.install
new file mode 100644
index 000000000..83c5e777b
--- /dev/null
+++ b/ubuntu/_base/dependencies/akode/debian/libakode2-ffmpeg.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/libakode_ffmpeg_decoder.so
diff --git a/ubuntu/_base/dependencies/akode/debian/patches/series b/ubuntu/_base/dependencies/akode/debian/patches/series
index 8b1378917..e69de29bb 100644
--- a/ubuntu/_base/dependencies/akode/debian/patches/series
+++ b/ubuntu/_base/dependencies/akode/debian/patches/series
@@ -1 +0,0 @@
-
diff --git a/ubuntu/_base/dependencies/akode/debian/rules b/ubuntu/_base/dependencies/akode/debian/rules
index d93e5d960..1788b4f36 100755
--- a/ubuntu/_base/dependencies/akode/debian/rules
+++ b/ubuntu/_base/dependencies/akode/debian/rules
@@ -23,7 +23,7 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DWITH_ALL_OPTIONS="ON" \
-DWITH_LIBLTDL="OFF" \
- -DWITH_FFMPEG_DECODER="OFF"
+ -DWITH_FFMPEG_DECODER="ON"
common-install-prehook-arch::
grep -v libakode_alsa_sink debian/libakode2.install > debian/libakode2.install.kfreebsd-i386