summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqtinterface/debian/rules28
1 files changed, 7 insertions, 21 deletions
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/rules b/ubuntu/_base/dependencies/tqtinterface/debian/rules
index fe114f5e8..0db17ad7b 100755
--- a/ubuntu/_base/dependencies/tqtinterface/debian/rules
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/rules
@@ -1,35 +1,21 @@
#! /usr/bin/make -f
-# see debian/rules file for tdesvn for cmake examples
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_KDE_APIDOX := yes
+include debian/cdbs/debian-tde.mk
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
- sed -e "s|.*version ||" -e "s| .*||" | \
- xargs -r dpkg --compare-versions 1.17.0 lt \
- && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
endif
-# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
-# never build in parallel, regardless of DEB_BUILD_OPTIONS.
-DEB_BUILD_PARALLEL ?= true
-
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR)