summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqtinterface/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/tqtinterface/debian')
-rw-r--r--ubuntu/_base/dependencies/tqtinterface/debian/cdbs/debian-tde.mk7
-rw-r--r--ubuntu/_base/dependencies/tqtinterface/debian/compat2
-rw-r--r--ubuntu/_base/dependencies/tqtinterface/debian/control2
-rwxr-xr-xubuntu/_base/dependencies/tqtinterface/debian/rules9
4 files changed, 16 insertions, 4 deletions
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/cdbs/debian-tde.mk b/ubuntu/_base/dependencies/tqtinterface/debian/cdbs/debian-tde.mk
index f36e3527c..aba508624 100644
--- a/ubuntu/_base/dependencies/tqtinterface/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/cdbs/debian-tde.mk
@@ -82,7 +82,7 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/compat b/ubuntu/_base/dependencies/tqtinterface/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/dependencies/tqtinterface/debian/compat
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/control b/ubuntu/_base/dependencies/tqtinterface/debian/control
index 4bd9ab301..88c437114 100644
--- a/ubuntu/_base/dependencies/tqtinterface/debian/control
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/control
@@ -2,7 +2,7 @@ Source: libtqtinterface
Section: tde
Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake-trinity, ninja-build, libtqt3-mt-dev, tqt3-apps-dev
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, libtqt3-mt-dev, tqt3-apps-dev
Standards-Version: 3.8.4
Package: libtqtinterface
diff --git a/ubuntu/_base/dependencies/tqtinterface/debian/rules b/ubuntu/_base/dependencies/tqtinterface/debian/rules
index 5772f17f6..0db17ad7b 100755
--- a/ubuntu/_base/dependencies/tqtinterface/debian/rules
+++ b/ubuntu/_base/dependencies/tqtinterface/debian/rules
@@ -7,8 +7,15 @@ include debian/cdbs/debian-tde.mk
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR)