summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/amarok/debian/cdbs
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/amarok/debian/cdbs')
-rw-r--r--ubuntu/maverick/applications/amarok/debian/cdbs/debian-qt-kde.mk11
-rw-r--r--ubuntu/maverick/applications/amarok/debian/cdbs/kde.mk8
2 files changed, 15 insertions, 4 deletions
diff --git a/ubuntu/maverick/applications/amarok/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/amarok/debian/cdbs/debian-qt-kde.mk
index 888f4be38..47e83ef4a 100644
--- a/ubuntu/maverick/applications/amarok/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/amarok/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,9 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -93,6 +96,14 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/maverick/applications/amarok/debian/cdbs/kde.mk b/ubuntu/maverick/applications/amarok/debian/cdbs/kde.mk
index 9dbcfbafd..5b6508f8c 100644
--- a/ubuntu/maverick/applications/amarok/debian/cdbs/kde.mk
+++ b/ubuntu/maverick/applications/amarok/debian/cdbs/kde.mk
@@ -35,7 +35,7 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
-# include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +59,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
@@ -70,7 +70,7 @@ cleanbuilddir::
common-build-arch common-build-indep:: debian/stamp-kde-apidox
debian/stamp-kde-apidox:
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
touch $@
common-install-prehook-impl::
@@ -82,7 +82,7 @@ common-install-prehook-impl::
common-install-arch common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
clean::
rm -f debian/stamp-kde-apidox