summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/k3b/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/k3b/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/k3b/debian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/k3b/debian/rules b/ubuntu/maverick/applications/k3b/debian/rules
index a0571a2de..8dbc7d2d9 100755
--- a/ubuntu/maverick/applications/k3b/debian/rules
+++ b/ubuntu/maverick/applications/k3b/debian/rules
@@ -1,6 +1,7 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/kde.mk
@@ -13,6 +14,17 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_CONFIGURE_EXTRA_FLAGS = --with-k3bsetup=no --with-extra-libs=/opt/trinity/lib --includedir="/opt/trinity/include/tde"
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
+
DEB_INSTALL_MANPAGES_k3b = debian/k3b.1
DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp/
@@ -23,6 +35,7 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
post-patches:: debian/stamp-bootstrap
debian/stamp-bootstrap:
+ifndef _cdbs_class_cmake
ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
endif
@@ -35,4 +48,5 @@ endif
cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
make -f admin/Makefile.common cvs
+endif
touch debian/stamp-bootstrap