summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/metapackages/trinity-keyring/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/metapackages/trinity-keyring/debian')
-rw-r--r--ubuntu/maverick/metapackages/trinity-keyring/debian/changelog6
-rw-r--r--ubuntu/maverick/metapackages/trinity-keyring/debian/control13
-rw-r--r--ubuntu/maverick/metapackages/trinity-keyring/debian/copyright27
-rw-r--r--ubuntu/maverick/metapackages/trinity-keyring/debian/postinst5
-rw-r--r--ubuntu/maverick/metapackages/trinity-keyring/debian/prerm9
-rwxr-xr-xubuntu/maverick/metapackages/trinity-keyring/debian/rules63
6 files changed, 123 insertions, 0 deletions
diff --git a/ubuntu/maverick/metapackages/trinity-keyring/debian/changelog b/ubuntu/maverick/metapackages/trinity-keyring/debian/changelog
new file mode 100644
index 000000000..cd0f0d940
--- /dev/null
+++ b/ubuntu/maverick/metapackages/trinity-keyring/debian/changelog
@@ -0,0 +1,6 @@
+trinity-keyring (2011.11.01-1) maverick; urgency=low
+
+ * NIGHTLY BUILDS
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Mon, 28 Oct 2011 11:39:00 -0600
+
diff --git a/ubuntu/maverick/metapackages/trinity-keyring/debian/control b/ubuntu/maverick/metapackages/trinity-keyring/debian/control
new file mode 100644
index 000000000..c61c58fba
--- /dev/null
+++ b/ubuntu/maverick/metapackages/trinity-keyring/debian/control
@@ -0,0 +1,13 @@
+Source: trinity-keyring
+Section: misc
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Standards-Version: 3.8.4
+
+Package: trinity-keyring
+Priority: important
+Architecture: all
+Depends: gnupg (>= 1.0.6-4)
+Description: GnuPG key of the Trinity Desktop Environment repository
+ The Trinity repository digitally signs its Release files. This package
+ contains the repository key used for that.
diff --git a/ubuntu/maverick/metapackages/trinity-keyring/debian/copyright b/ubuntu/maverick/metapackages/trinity-keyring/debian/copyright
new file mode 100644
index 000000000..d934ced33
--- /dev/null
+++ b/ubuntu/maverick/metapackages/trinity-keyring/debian/copyright
@@ -0,0 +1,27 @@
+This is Debian GNU's GnuPG keyrings of archive keys.
+
+This package was originally put together by Michael Vogt
+<mvo@debian.org>
+
+The keys in the keyrings don't fall under any copyright. Everything
+else in the package is covered by the GNU GPL.
+
+Debian support files Copyright (C) 2006 Michael Vogt <mvo@debian.org>
+based on the debian-keyring package maintained by James Troup
+
+Debian support files for debian-archive-keyring are free software; you
+can redistribute them and/or modify them under the terms of the GNU
+General Public License as published by the Free Software Foundation;
+either version 2, or (at your option) any later version.
+
+Debian support files for debian-archive-keyring are distributed in the
+hope that they will be useful, but WITHOUT ANY WARRANTY; without even
+the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
+PURPOSE. See the GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License with
+your Debian system, in /usr/share/common-licenses/GPL, or with the
+Debian GNU debian-archive-keyring source package as the file COPYING.
+If not, write to the Free Software Foundation, Inc., 51 Franklin Street,
+Fifth Floor, Boston, MA 02110-1301 USA.
+
diff --git a/ubuntu/maverick/metapackages/trinity-keyring/debian/postinst b/ubuntu/maverick/metapackages/trinity-keyring/debian/postinst
new file mode 100644
index 000000000..fa0073eba
--- /dev/null
+++ b/ubuntu/maverick/metapackages/trinity-keyring/debian/postinst
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ -x /usr/bin/apt-key ]; then
+ /usr/bin/apt-key add /usr/share/keyrings/trinity-keyring.gpg
+fi
diff --git a/ubuntu/maverick/metapackages/trinity-keyring/debian/prerm b/ubuntu/maverick/metapackages/trinity-keyring/debian/prerm
new file mode 100644
index 000000000..4af539bb3
--- /dev/null
+++ b/ubuntu/maverick/metapackages/trinity-keyring/debian/prerm
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case "$1" in
+ remove|purge)
+ if [ -x /usr/bin/apt-key ]; then
+ /usr/bin/apt-key del 2B8638D0
+ fi
+ ;;
+esac
diff --git a/ubuntu/maverick/metapackages/trinity-keyring/debian/rules b/ubuntu/maverick/metapackages/trinity-keyring/debian/rules
new file mode 100755
index 000000000..8695ad9dc
--- /dev/null
+++ b/ubuntu/maverick/metapackages/trinity-keyring/debian/rules
@@ -0,0 +1,63 @@
+#!/usr/bin/make -f
+# debian/rules file - for debian/keyring
+# Based on sample debian/rules file - for GNU Hello (1.3).
+# Copyright 1994,1995 by Ian Jackson.
+# Copyright 1998-2003 James Troup
+# I hereby give you perpetual unlimited permission to copy,
+# modify and relicense this file, provided that you do not remove
+# my name from the file itself. (I assert my moral right of
+# paternity under the Copyright, Designs and Patents Act 1988.)
+# This file may have to be extensively modified
+
+install_dir=install -d -m 755
+install_file=install -m 644
+install_script=install -m 755
+install_binary=install -m 755 -s
+
+VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DISTRIBUTION := $(shell dpkg-parsechangelog | grep ^Distribution: | cut -d' ' -f2)
+
+build:
+
+clean:
+ $(checkdir)
+ -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
+ -rm -rf debian/tmp
+
+binary-indep: checkroot
+ $(checkdir)
+ -rm -rf debian/tmp
+ $(install_dir) debian/tmp/DEBIAN/
+ $(install_script) debian/postinst debian/tmp/DEBIAN/
+ $(install_script) debian/prerm debian/tmp/DEBIAN/
+
+ $(install_dir) debian/tmp/usr/share/keyrings/
+ $(install_file) keyrings/trinity-keyring.gpg debian/tmp/usr/share/keyrings/
+ $(install_dir) debian/tmp/etc/apt/sources.list.d/
+ $(install_file) repositories/trinity.list debian/tmp/etc/apt/sources.list.d/
+ sed -i 's|ubuntu [^ ]* main|ubuntu ${DISTRIBUTION} main|g' debian/tmp/etc/apt/sources.list.d/trinity.list
+
+ $(install_dir) debian/tmp/usr/share/doc/trinity-keyring/
+ $(install_file) debian/changelog debian/tmp/usr/share/doc/trinity-keyring/changelog
+ $(install_file) debian/copyright debian/tmp/usr/share/doc/trinity-keyring/
+
+ dpkg-gencontrol -ptrinity-keyring -isp
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+binary-arch:
+
+define checkdir
+ test -f keyrings/trinity-keyring.gpg
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot