summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-30 07:56:33 +0200
committergregory guy <gregory-tde@laposte.net>2020-09-30 07:56:33 +0200
commit07a6d98c1b4a852cfaca3ac02b388351909d7b9c (patch)
tree7ae753dd05ae4e8e8fcee9c3cd3501907ac0a982 /CMakeLists.txt
parentb986718d988717c5321022729cdcc731820709d3 (diff)
downloadtde-style-lipstik-07a6d98c1b4a852cfaca3ac02b388351909d7b9c.tar.gz
tde-style-lipstik-07a6d98c1b4a852cfaca3ac02b388351909d7b9c.zip
Drop automake build support.
Add basic cmake build instructions. Deleted empty file NEWS. Deleted spec file (rpm) lipstik.spec. Rework of the README file. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 327cea1..381ed8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )