summaryrefslogtreecommitdiffstats
path: root/config/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-05 18:12:45 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-05 18:12:45 +0000
commitb23b8edce7cbd48165084dbd852875afeb800735 (patch)
tree6fce139d187944d762e804b4e868e8a40284a121 /config/CMakeLists.txt
parent70f7d26b3b2a811ad0000cc3a26e21142d34e39f (diff)
downloadtde-style-qtcurve-b23b8edce7cbd48165084dbd852875afeb800735.tar.gz
tde-style-qtcurve-b23b8edce7cbd48165084dbd852875afeb800735.zip
Update qtcurve to latest upstream version
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kde-style-qtcurve@1182805 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'config/CMakeLists.txt')
-rw-r--r--config/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
index b9b391f..3c02ea9 100644
--- a/config/CMakeLists.txt
+++ b/config/CMakeLists.txt
@@ -1,7 +1,12 @@
-set(kstyle_qtcurve_config_PART_SRCS qtcurveconfig.cpp exportthemedialog.cpp)
+if (QTC_STYLE_SUPPORT)
+ set(kstyle_qtcurve_config_PART_SRCS qtcurveconfig.cpp exportthemedialog.cpp)
+else (QTC_STYLE_SUPPORT)
+ set(kstyle_qtcurve_config_PART_SRCS qtcurveconfig.cpp)
+endif (QTC_STYLE_SUPPORT)
+
include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/common ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_BINARY_DIR} ${KDE3_INCLUDE_DIR} ${QT_INCLUDE_DIR})
kde3_add_ui_files(kstyle_qtcurve_config_PART_SRCS qtcurveconfigbase.ui)
kde3_add_kpart(kstyle_qtcurve_config ${kstyle_qtcurve_config_PART_SRCS})
kde3_automoc(${kstyle_qtcurve_config_PART_SRCS})
-target_link_libraries(kstyle_qtcurve_config ${KDE3_KDEUI_LIBS} ${KDE3_KIO_LIBS} ${KDE3_KDECORE_LIBS} ${QT_QTGUI_LIBRARY})
+target_link_libraries(kstyle_qtcurve_config ${QT_AND_KDECORE_LIBS} kio kdeui)
install(TARGETS kstyle_qtcurve_config DESTINATION ${KDE3_LIB_DIR}/kde3)