summaryrefslogtreecommitdiffstats
path: root/kttsd/players/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-29 19:41:28 +0200
committergregory guy <gregory-tde@laposte.net>2021-01-26 11:52:09 +0100
commit6b3181cf92f1fc74da1e8a82f690a1526cb4e900 (patch)
treeb2bcaa0683427ddc2a1d692870d731c238f6cce8 /kttsd/players/CMakeLists.txt
parente09ebe446c909827c78f7c6d76b94ce4adea139d (diff)
downloadtdeaccessibility-6b3181cf92f1fc74da1e8a82f690a1526cb4e900.tar.gz
tdeaccessibility-6b3181cf92f1fc74da1e8a82f690a1526cb4e900.zip
Conversion to the cmake building system.
Added several man pages taken from the Debian packaging. Cleanup headers in ui files. Add png icons for mono theme. Signed-off-by: gregory guy <gregory-tde@laposte.net> cmake: - Use tde_add_check_executable instead of a combination of separate calls to tde_add_executable and add_test. - Simplify the detection of time.h and sys/time.h headers. - Refactor phrasebook files install, kmouth. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kttsd/players/CMakeLists.txt')
-rw-r--r--kttsd/players/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/kttsd/players/CMakeLists.txt b/kttsd/players/CMakeLists.txt
new file mode 100644
index 0000000..12cabb0
--- /dev/null
+++ b/kttsd/players/CMakeLists.txt
@@ -0,0 +1,12 @@
+tde_conditional_add_subdirectory( WITH_ARTS artsplayer )
+tde_conditional_add_subdirectory( WITH_AKODE akodeplayer )
+tde_conditional_add_subdirectory( WITH_ALSA alsaplayer )
+tde_conditional_add_subdirectory( WITH_GSTREAMER gstplayer )
+
+
+##### other data
+
+tde_create_translated_desktop(
+ SOURCE kttsd_audioplugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+)