summaryrefslogtreecommitdiffstats
path: root/kate/kjswrapper/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /kate/kjswrapper/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kate/kjswrapper/Makefile.am')
-rw-r--r--kate/kjswrapper/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kate/kjswrapper/Makefile.am b/kate/kjswrapper/Makefile.am
new file mode 100644
index 0000000..51258f7
--- /dev/null
+++ b/kate/kjswrapper/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS= . samples
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = katekjswrapperplugin.la
+
+# This is all standard. Remove the LIB_KHTML reference if you are not
+# using the KHTML Part
+katekjswrapperplugin_la_SOURCES = plugin_katekjswrapper.cpp bindings.cpp
+katekjswrapperplugin_la_LIBADD = -lkateinterfaces -lkjsembed -lkjs
+katekjswrapperplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/katekjswrapper.pot
+