summaryrefslogtreecommitdiffstats
path: root/noatun-plugins/luckytag/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun-plugins/luckytag/Makefile.am')
-rw-r--r--noatun-plugins/luckytag/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/noatun-plugins/luckytag/Makefile.am b/noatun-plugins/luckytag/Makefile.am
new file mode 100644
index 0000000..4e02899
--- /dev/null
+++ b/noatun-plugins/luckytag/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES= $(all_includes)
+kde_module_LTLIBRARIES = noatunluckytag.la
+
+noatunluckytag_la_SOURCES = luckytag.cpp parsedmp3filename.cpp
+noatunluckytag_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatunluckytag_la_LIBADD = $(LIB_KFILE) -lnoatun -lnoatuntags
+
+noatunluckytag_la_METASOURCES = AUTO
+
+noatun_DATA = luckytag.plugin
+noatundir = $(kde_datadir)/noatun