summaryrefslogtreecommitdiffstats
path: root/kcron/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2018-08-11 09:09:44 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-01 18:41:34 +0200
commit88073834d0052272dce61556b9508e66b84cd494 (patch)
tree8df27acc26daca7dc9e6f15e134932cbb08d324b /kcron/CMakeLists.txt
parentb2bfb5e920d347f2f272c21e2d24cda1c943a4d5 (diff)
downloadtdeadmin-88073834d0052272dce61556b9508e66b84cd494.tar.gz
tdeadmin-88073834d0052272dce61556b9508e66b84cd494.zip
First bach of cmake files in order to convert tdeadmin
from autotools to cmake building system.
Diffstat (limited to 'kcron/CMakeLists.txt')
-rw-r--r--kcron/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kcron/CMakeLists.txt b/kcron/CMakeLists.txt
new file mode 100644
index 0000000..66cd953
--- /dev/null
+++ b/kcron/CMakeLists.txt
@@ -0,0 +1,42 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kcron (executable) ########################
+
+tde_add_executable( kcron AUTOMOC
+ SOURCES cthost.cpp ctcron.cpp ctmonth.cpp ctdom.cpp ctdow.cpp cttask.cpp
+ ctvariable.cpp kticon.cpp ktapp.cpp ktview.cpp ktlistitem.cpp
+ ktlistcron.cpp ktlisttask.cpp ktlisttasks.cpp ktlistvar.cpp ktlistvars.cpp
+ kttask.cpp ktvariable.cpp ktprint.cpp ktprintopt.cpp main.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdeprint-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kcron )
+
+
+##### other data ################################
+
+install( FILES kcronui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kcron
+)
+
+install( FILES kcron.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)