summaryrefslogtreecommitdiffstats
path: root/kuser/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2018-08-11 09:09:44 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-01 18:41:34 +0200
commit88073834d0052272dce61556b9508e66b84cd494 (patch)
tree8df27acc26daca7dc9e6f15e134932cbb08d324b /kuser/CMakeLists.txt
parentb2bfb5e920d347f2f272c21e2d24cda1c943a4d5 (diff)
downloadtdeadmin-88073834d0052272dce61556b9508e66b84cd494.tar.gz
tdeadmin-88073834d0052272dce61556b9508e66b84cd494.zip
First bach of cmake files in order to convert tdeadmin
from autotools to cmake building system.
Diffstat (limited to 'kuser/CMakeLists.txt')
-rw-r--r--kuser/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/kuser/CMakeLists.txt b/kuser/CMakeLists.txt
new file mode 100644
index 0000000..2ecfd90
--- /dev/null
+++ b/kuser/CMakeLists.txt
@@ -0,0 +1,47 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( pic )
+add_subdirectory( toolbar )
+add_subdirectory( icon )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kuser
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kuser (executable) ########################
+
+tde_add_executable( kuser AUTOMOC
+ SOURCES mainWidget.cpp editGroup.cpp kuservw.cpp kgroupvw.cpp delUser.cpp
+ kuser.cpp kgroup.cpp main.cpp mainView.cpp propdlg.cpp misc.cpp pwddlg.cpp
+ addUser.cpp editDefaults.cpp tdeglobal.cpp sid.cpp kuserfiles.cpp
+ kgroupfiles.cpp kuserldap.cpp kgroupldap.cpp kusersystem.cpp
+ kgroupsystem.cpp selectconn.cpp sha1.cpp kuserprefs.kcfgc filessettings.ui
+ generalsettings.ui ldapsettings.ui ldapsamba.ui passwordpolicy.ui
+ LINK tdecore-shared tdeui-shared tdeio-shared tdeui-shared crypt tdeabc_ldaptdeio tdeabc ldap
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES kuserui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kuser
+)
+
+install( FILES kuser.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kuser.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)