summaryrefslogtreecommitdiffstats
path: root/knetworkconf/knetworkconf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'knetworkconf/knetworkconf/CMakeLists.txt')
-rw-r--r--knetworkconf/knetworkconf/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/knetworkconf/knetworkconf/CMakeLists.txt b/knetworkconf/knetworkconf/CMakeLists.txt
new file mode 100644
index 0000000..a00d070
--- /dev/null
+++ b/knetworkconf/knetworkconf/CMakeLists.txt
@@ -0,0 +1,45 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+add_definitions( -UQT_NO_COMPAT
+)
+
+
+##### kcm_knetworkconfmodule (kpart) ############
+
+tde_add_kpart( kcm_knetworkconfmodule AUTOMOC
+ SOURCES tdeselectdistrodlg.ui kknownhostinfo.cpp kinterfaceupdowndlg.ui
+ kaddknownhostdlg.ui kdetectdistrodlg.ui knetworkconfmodule.cpp
+ kroutinginfo.cpp kreloadnetworkdlg.ui kaddressvalidator.cpp kdnsinfo.cpp
+ knetworkinfo.cpp kadddevicedlg.ui kadddnsserverdlg.ui
+ knetworkconfigparser.cpp knetworkinterface.cpp knetworkconfdlg.ui
+ knetworkconf.cpp main.cpp kadddevicedlgextension.ui knetworkconfiface.skel
+ kwirelessinterface.cpp kadddevicewifiext.ui kadddevicecontainer.cpp
+ kprofileslistviewtooltip.cpp
+ LINK tdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( )
+
+
+##### other data ################################
+
+install( FILES kcm_knetworkconfmodule.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)