summaryrefslogtreecommitdiffstats
path: root/kpackage/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kpackage/Makefile.am')
-rw-r--r--kpackage/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/kpackage/Makefile.am b/kpackage/Makefile.am
new file mode 100644
index 0000000..4f2791f
--- /dev/null
+++ b/kpackage/Makefile.am
@@ -0,0 +1,36 @@
+
+xdg_apps_DATA = kpackage.desktop
+
+# claim, which subdirectories you want to install
+SUBDIRS = pics toolbar icon
+
+bin_PROGRAMS = kpackage
+
+# Which sources should be compiled for kpackage.
+kpackage_SOURCES = kpackage.cpp managementWidget.cpp packageDisplay.cpp \
+ packageProperties.cpp findf.cpp search.cpp \
+ options.cpp pkgOptions.cpp \
+ packageInfo.cpp cache.cpp main.cpp utils.cpp kio.cpp \
+ debInterface.cpp debDpkgInterface.cpp debAptInterface.cpp \
+ updateLoc.cpp procbuf.cpp kplview.cpp \
+ pkgInterface.cpp rpmInterface.cpp kissInterface.cpp \
+ slackInterface.cpp fbsdInterface.cpp gentooInterface.cpp \
+ kpPty.cpp kpTerm.cpp
+
+kpackage_METASOURCES = AUTO
+
+# the library search path
+kpackage_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+# the libraries to link against. Be aware of the order. First the libraries,
+# that depend on the following ones.
+kpackage_LDADD = $(LIB_KFILE) $(LIBINTL) $(LIBZ) $(LIBUTEMPTER)
+
+INCLUDES = $(all_includes)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kpackage.pot
+
+rcdir = $(kde_datadir)/kpackage
+rc_DATA = kpackageui.rc
+