summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdb7eae1..aa21a357 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,12 +43,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
-option( WITH_XSCREENSAVER "Enable xscreensavers support" ${WITH_ALL_OPTIONS} )
-option( WITH_ALL_INCLUDED_XSCREENSAVERS "Install all included desktop files" OFF ) #regardless of the presence of XML
-option( WITH_LIBART "Enable libart support" ${WITH_ALL_OPTIONS} )
-option( WITH_OPENGL "Enable 3D GL modes" ${WITH_ALL_OPTIONS} )
-option( WITH_ARTS "Enable aRts support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_XSCREENSAVER "Enable xscreensavers support" ${WITH_ALL_OPTIONS} )
+option( WITH_ALL_INCLUDED_XSCREENSAVERS "Install all included desktop files" ${WITH_ALL_OPTIONS} ) #regardless of the presence of XML
+option( WITH_LIBART "Enable libart support" ${WITH_ALL_OPTIONS} )
+option( WITH_OPENGL "Enable 3D GL modes" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
########### options comments ##############
# #