summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2014-04-06 03:46:07 +0400
committerSlávek Banko <slavek.banko@axis.cz>2014-04-29 01:48:57 +0200
commit3c75381e05b6443906527f2c2513455309578ea8 (patch)
treeba44aa3cc2a94b6bdc1bd097c0c6f45fd7fd1242 /CMakeLists.txt
parent9fb2cb290edabb9b2f382256d8370adc5ae73a50 (diff)
downloadtdebase-3c75381e05b6443906527f2c2513455309578ea8.tar.gz
tdebase-3c75381e05b6443906527f2c2513455309578ea8.zip
Remove useless cmake configuration options WITH_XEXT and WITH_XDAMAGE
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1b7e79bd..35ff873d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,8 +71,6 @@ option( WITH_XCURSOR "Enable xcursor support" ${WITH_ALL_OPTIONS} )
option( WITH_XFIXES "Enable xfixes support" ${WITH_ALL_OPTIONS} )
option( WITH_XRANDR "Enable xrandr support" ${WITH_ALL_OPTIONS} )
option( WITH_XRENDER "Enable xrender support" ${WITH_ALL_OPTIONS} )
-option( WITH_XDAMAGE "Enable xdamage support" ${WITH_ALL_OPTIONS} )
-option( WITH_XEXT "Enable xext support" ${WITH_ALL_OPTIONS} )
option( WITH_LIBCONFIG "Enable libconfig support" ${WITH_ALL_OPTIONS} )
option( WITH_XTEST "Enable xtest support" ${WITH_ALL_OPTIONS} )
option( WITH_OPENGL "Enable openGL support" ${WITH_ALL_OPTIONS} )
@@ -104,8 +102,6 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# WITH_XCOMPOSITE affects twin kicker(taskmanager) tdm
# WITH_XCURSOR affects tdeioslaves(thumbnail), kcontrol(input), kdesktop
# WITH_XFIXES affects twin klipper kicker(taskmanager)
-# WITH_XDAMAGE affects <nothing>
-# WITH_XEXT affects <nothing>
# WITH_XRANDR affects tdm, kcontrol(displayconfig randr iccconfig)
# WITH_XRENDER affects twin konsole kicker(taskmanager) kdesktop
# kcontrol(style)
@@ -136,10 +132,6 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# NOTE: if WITH_XCOMPOSITE=ON then the following options are also required:
# WITH_XRENDER=ON
# WITH_XFIXES=ON
-# WITH_XDAMAGE=ON
-# WITH_XEXT=ON
-# NOTE: seems WITH_XDAMAGE and WITH_XET doesn't change anything
-# they are just required by WITH_XCOMPOSITE
##### user requested modules ####################