summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-11 16:27:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-11 16:27:15 -0600
commit3d1f4dadffc27428cf198685822cd30003a36417 (patch)
tree2c83a9a9ac36df2b479182b53f3e91dfeb15065a /CMakeLists.txt
parent51ff055d6ce9e93584818d5e80e42fa9cb1da0a3 (diff)
downloadtdebase-3d1f4dadffc27428cf198685822cd30003a36417.tar.gz
tdebase-3d1f4dadffc27428cf198685822cd30003a36417.zip
Add WITH_ALL_OPTIONS to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt47
1 files changed, 24 insertions, 23 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a84947806..acfcc2d6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,29 +54,30 @@ add_custom_target(install-apidox
##### optional stuff ############################
-option( WITH_SASL "Enable SASL support" OFF )
-option( WITH_LDAP "Enable LDAP support" OFF )
-option( WITH_SAMBA "Enable SAMBA support" OFF )
-option( WITH_OPENEXR "Enable openexr support" OFF )
-option( WITH_XCOMPOSITE "Enable xcomposite support" OFF )
-option( WITH_XCURSOR "Enable xcursor support" OFF )
-option( WITH_XFIXES "Enable xfixes support" OFF )
-option( WITH_XRANDR "Enable xrandr support" OFF )
-option( WITH_XRENDER "Enable xrender support" OFF )
-option( WITH_XDAMAGE "Enable xdamage support" OFF )
-option( WITH_XEXT "Enable xext support" OFF )
-option( WITH_XTEST "Enable xext support" OFF )
-option( WITH_LIBUSB "Enable control of some mouse models through libusb" OFF )
-option( WITH_LIBRAW1394 "Enable visualization of ieee1394 devices through libraw1394" OFF )
-option( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" OFF )
-option( WITH_PAM "kdm should use PAM" OFF )
-option( WITH_SHADOW "kdm should use shadow passwords" OFF )
-option( WITH_XDMCP "xdmcp support for kdm" OFF )
-option( WITH_XINERAMA "Enable xinerama extension support" OFF )
-option( WITH_ARTS "Enable aRts support" OFF )
-option( WITH_I8K "Enable Dell laptop support (ksysguard)" OFF )
-option( WITH_HAL "Enable HAL support" OFF )
-option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_SASL "Enable SASL support" ${WITH_ALL_OPTIONS} )
+option( WITH_LDAP "Enable LDAP support" ${WITH_ALL_OPTIONS} )
+option( WITH_SAMBA "Enable SAMBA support" ${WITH_ALL_OPTIONS} )
+option( WITH_OPENEXR "Enable openexr support" ${WITH_ALL_OPTIONS} )
+option( WITH_XCOMPOSITE "Enable xcomposite support" ${WITH_ALL_OPTIONS} )
+option( WITH_XCURSOR "Enable xcursor support" ${WITH_ALL_OPTIONS} )
+option( WITH_XFIXES "Enable xfixes support" ${WITH_ALL_OPTIONS} )
+option( WITH_XRANDR "Enable xrandr support" ${WITH_ALL_OPTIONS} )
+option( WITH_XRENDER "Enable xrender support" ${WITH_ALL_OPTIONS} )
+option( WITH_XDAMAGE "Enable xdamage support" ${WITH_ALL_OPTIONS} )
+option( WITH_XEXT "Enable xext support" ${WITH_ALL_OPTIONS} )
+option( WITH_XTEST "Enable xext support" ${WITH_ALL_OPTIONS} )
+option( WITH_LIBUSB "Enable control of some mouse models through libusb" ${WITH_ALL_OPTIONS} )
+option( WITH_LIBRAW1394 "Enable visualization of ieee1394 devices through libraw1394" ${WITH_ALL_OPTIONS} )
+option( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" ${WITH_ALL_OPTIONS} )
+option( WITH_PAM "kdm should use PAM" ${WITH_ALL_OPTIONS} )
+option( WITH_SHADOW "kdm should use shadow passwords" ${WITH_ALL_OPTIONS} )
+option( WITH_XDMCP "xdmcp support for kdm" ${WITH_ALL_OPTIONS} )
+option( WITH_XINERAMA "Enable xinerama extension support" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
+option( WITH_I8K "Enable Dell laptop support (ksysguard)" ${WITH_ALL_OPTIONS} )
+option( WITH_HAL "Enable HAL support" ${WITH_ALL_OPTIONS} )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules ####################