summaryrefslogtreecommitdiffstats
path: root/kcontrol/kthememanager/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/kthememanager/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/kthememanager/Makefile.am')
-rw-r--r--kcontrol/kthememanager/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kcontrol/kthememanager/Makefile.am b/kcontrol/kthememanager/Makefile.am
new file mode 100644
index 000000000..be71094cb
--- /dev/null
+++ b/kcontrol/kthememanager/Makefile.am
@@ -0,0 +1,21 @@
+AM_CPPFLAGS = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kcm_kthememanager.la
+
+kcm_kthememanager_la_SOURCES = kthemedlg.ui newthemewidget.ui knewthemedlg.cpp ktheme.cpp kthememanager.cpp
+kcm_kthememanager_la_LIBADD = $(LIB_KIO)
+kcm_kthememanager_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+
+noinst_HEADERS = kthememanager.h ktheme.h knewthemedlg.h kthemedlg.ui.h
+
+xdg_apps_DATA = kthememanager.desktop installktheme.desktop
+
+# MIME type
+kthememime_DATA = x-ktheme.desktop
+kthememimedir = $(kde_mimedir)/application
+
+bin_SCRIPTS = kdeinstallktheme
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kthememanager.pot