summaryrefslogtreecommitdiffstats
path: root/kcontrol/smartcard/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kcontrol/smartcard/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kcontrol/smartcard/Makefile.am')
-rw-r--r--kcontrol/smartcard/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kcontrol/smartcard/Makefile.am b/kcontrol/smartcard/Makefile.am
new file mode 100644
index 000000000..940dfaacc
--- /dev/null
+++ b/kcontrol/smartcard/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = $(all_includes)
+kde_module_LTLIBRARIES = kcm_smartcard.la
+
+kcm_smartcard_la_SOURCES = smartcard.cpp smartcardbase.ui nosmartcardbase.ui smartcard.skel
+
+kcm_smartcard_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+
+kcm_smartcard_la_LIBADD = -lkdeui -lksmartcard $(LIB_KIO)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = smartcard.h
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmsmartcard.pot
+
+xdg_apps_DATA = smartcard.desktop