summaryrefslogtreecommitdiffstats
path: root/kcontrol/tdefontinst/tdefontinst/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-01 17:25:42 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-01 17:25:42 -0600
commiteba183d4de47093c6e44a99c8d7fe313aa2834c9 (patch)
tree53f8d1a08bd16668cb9040b2aaf9a041314b2003 /kcontrol/tdefontinst/tdefontinst/CMakeLists.txt
parentf537c21b68e08f649b1b297bce8f3904603137e0 (diff)
downloadtdebase-eba183d4de47093c6e44a99c8d7fe313aa2834c9.tar.gz
tdebase-eba183d4de47093c6e44a99c8d7fe313aa2834c9.zip
Fix FTBFS
Diffstat (limited to 'kcontrol/tdefontinst/tdefontinst/CMakeLists.txt')
-rw-r--r--kcontrol/tdefontinst/tdefontinst/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/kcontrol/tdefontinst/tdefontinst/CMakeLists.txt b/kcontrol/tdefontinst/tdefontinst/CMakeLists.txt
new file mode 100644
index 000000000..fdcb51b15
--- /dev/null
+++ b/kcontrol/tdefontinst/tdefontinst/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions( -DOS_${CMAKE_SYSTEM_NAME} )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kcontrol/kfontinst/lib
+ ${CMAKE_SOURCE_DIR}/kcontrol/fonts/
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${FREETYPE_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kfontinst (executable) ####################
+
+tde_add_executable( kfontinst
+ SOURCES
+ Main.cpp FontEngine.cpp Fontmap.cpp GetPid.c
+ XConfig.cpp
+ LINK kxftconfig-static kfontinst-shared tdeio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)