summaryrefslogtreecommitdiffstats
path: root/kdeprint/printmgr/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kdeprint/printmgr/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdeprint/printmgr/Makefile.am')
-rw-r--r--kdeprint/printmgr/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kdeprint/printmgr/Makefile.am b/kdeprint/printmgr/Makefile.am
new file mode 100644
index 000000000..b10f8359e
--- /dev/null
+++ b/kdeprint/printmgr/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_printmgr.la
+
+kcm_printmgr_la_SOURCES = kcmprintmgr.cpp
+kcm_printmgr_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_printmgr_la_LIBADD = -lkdeprint_management
+
+noinst_HEADERS = kcmprintmgr.h
+
+KDE_ICON = printmgr
+
+xdg_apps_DATA = printers.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmprintmgr.pot