summaryrefslogtreecommitdiffstats
path: root/kdesktop/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-07-03 20:10:17 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-07-03 20:11:06 +0900
commita359fef24e132b22b7a1667f826b0fb1bddf331f (patch)
treee0e40b2a64d576331c926aedfeb019b733fd94c2 /kdesktop/CMakeLists.txt
parent828bd2ad0c9d07fcbef8cc5ef113e19882cbe3d4 (diff)
downloadtdebase-a359fef24e132b22b7a1667f826b0fb1bddf331f.tar.gz
tdebase-a359fef24e132b22b7a1667f826b0fb1bddf331f.zip
Fixed session locking at login. This resolves bug 2874.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'kdesktop/CMakeLists.txt')
-rw-r--r--kdesktop/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/kdesktop/CMakeLists.txt b/kdesktop/CMakeLists.txt
index 45cc9e9ed..fcb84a66a 100644
--- a/kdesktop/CMakeLists.txt
+++ b/kdesktop/CMakeLists.txt
@@ -81,6 +81,8 @@ tde_add_executable( kxdglauncher
##### kdesktop (tdeinit) ########################
set( target kdesktop )
+set_source_files_properties( lockeng.cc PROPERTIES COMPILE_FLAGS -DKDE_CONFDIR=\\"${TDE_CONFIG_DIR}\\" )
+
set( ${target}_SRCS
main.cc krootwm.cc xautolock.cc kdiconview.cc init.cc