summaryrefslogtreecommitdiffstats
path: root/kicker/applets/naughty/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kicker/applets/naughty/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kicker/applets/naughty/Makefile.am')
-rw-r--r--kicker/applets/naughty/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/kicker/applets/naughty/Makefile.am b/kicker/applets/naughty/Makefile.am
new file mode 100644
index 000000000..533df19c3
--- /dev/null
+++ b/kicker/applets/naughty/Makefile.am
@@ -0,0 +1,30 @@
+pic_DATA = naughty-happy.png naughty-sad.png
+picdir = $(kde_datadir)/naughtyapplet/pics
+
+INCLUDES = -I$(top_srcdir)/kicker/libkicker $(all_includes)
+
+kde_module_LTLIBRARIES = naughty_panelapplet.la
+
+naughty_panelapplet_la_SOURCES = \
+ NaughtyProcessMonitor.cpp \
+ NaughtyConfigDialog.cpp \
+ NaughtyApplet.cpp
+
+METASOURCES = AUTO
+
+noinst_HEADERS = \
+ NaughtyProcessMonitor.h \
+ NaughtyConfigDialog.h \
+ NaughtyApplet.h
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = naughtyapplet.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+
+naughty_panelapplet_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+naughty_panelapplet_la_LIBADD = ../../libkicker/libkickermain.la $(LIB_KDEUI) $(LIB_KVM)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/naughtyapplet.pot
+