summaryrefslogtreecommitdiffstats
path: root/kioslave/trash/kfile-plugin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kioslave/trash/kfile-plugin/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslave/trash/kfile-plugin/Makefile.am')
-rw-r--r--kioslave/trash/kfile-plugin/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/kioslave/trash/kfile-plugin/Makefile.am b/kioslave/trash/kfile-plugin/Makefile.am
new file mode 100644
index 000000000..0668553a8
--- /dev/null
+++ b/kioslave/trash/kfile-plugin/Makefile.am
@@ -0,0 +1,14 @@
+## Makefile.am for trash file meta info plugin
+
+AM_CPPFLAGS = $(all_includes)
+
+kde_module_LTLIBRARIES = kfile_trash.la
+
+kfile_trash_la_SOURCES = kfile_trash.cpp
+kfile_trash_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_trash_la_LIBADD = ../libtrashcommon.la $(LIB_KIO)
+
+METASOURCES = AUTO
+
+services_DATA = kfile_trash.desktop kfile_trash_system.desktop
+servicesdir = $(kde_servicesdir)