summaryrefslogtreecommitdiffstats
path: root/konqueror/sidebar/web_module/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /konqueror/sidebar/web_module/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konqueror/sidebar/web_module/Makefile.am')
-rw-r--r--konqueror/sidebar/web_module/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/konqueror/sidebar/web_module/Makefile.am b/konqueror/sidebar/web_module/Makefile.am
new file mode 100644
index 000000000..64675d351
--- /dev/null
+++ b/konqueror/sidebar/web_module/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = -I$(srcdir)/../ -I$(srcdir)/../../../libkonq $(all_includes)
+
+kde_module_LTLIBRARIES = konqsidebar_web.la
+
+METASOURCES = AUTO
+
+konqsidebar_web_la_SOURCES = web_module.cpp
+konqsidebar_web_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+konqsidebar_web_la_LIBADD = $(LIB_KPARTS) $(LIB_KHTML) ../libkonqsidebarplugin.la ../../../libkonq/libkonq.la
+
+#plugindir=$(kde_datadir)/konqsidebartng/entries
+#plugin_DATA=websidebar.desktop
+
+pluginadddir=$(kde_datadir)/konqsidebartng/add
+pluginadd_DATA=webmodule_add.desktop
+
+htmldir=$(kde_datadir)/konqsidebartng/websidebar
+html_DATA=websidebar.html
+