summaryrefslogtreecommitdiffstats
path: root/kwin/clients/laptop/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kwin/clients/laptop/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kwin/clients/laptop/Makefile.am')
-rw-r--r--kwin/clients/laptop/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kwin/clients/laptop/Makefile.am b/kwin/clients/laptop/Makefile.am
new file mode 100644
index 000000000..eb870720a
--- /dev/null
+++ b/kwin/clients/laptop/Makefile.am
@@ -0,0 +1,17 @@
+
+INCLUDES = -I$(srcdir)/../../lib $(all_includes)
+
+kde_module_LTLIBRARIES = kwin3_laptop.la
+
+kwin3_laptop_la_SOURCES = laptopclient.cpp
+kwin3_laptop_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kwin3_laptop_la_LIBADD = ../../lib/libkdecorations.la
+
+METASOURCES = AUTO
+noinst_HEADERS = laptopclient.h
+
+lnkdir = $(kde_datadir)/kwin
+lnk_DATA = laptop.desktop
+
+EXTRA_DIST = $(lnk_DATA)
+