summaryrefslogtreecommitdiffstats
path: root/tdeioslave/nfs/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
commitde7e5867a65e0a46f1388e3e50bc7eeddd1aecbf (patch)
treedbb3152c372f8620f9290137d461f3d9f9eba1cb /tdeioslave/nfs/Makefile.am
parent936d3cec490c13f2c5f7dd14f5e364fddaa6da71 (diff)
downloadtdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.tar.gz
tdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/nfs/Makefile.am')
-rw-r--r--tdeioslave/nfs/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/tdeioslave/nfs/Makefile.am b/tdeioslave/nfs/Makefile.am
new file mode 100644
index 000000000..4ab02fc1d
--- /dev/null
+++ b/tdeioslave/nfs/Makefile.am
@@ -0,0 +1,28 @@
+## Makefile.am of tdebase/tdeioslave/man
+
+INCLUDES= $(all_includes)
+AM_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+
+####### Files
+
+kde_module_LTLIBRARIES = kio_nfs.la
+
+kio_nfs_la_SOURCES = kio_nfs.cpp mount_xdr.c nfs_prot_xdr.c
+kio_nfs_la_LIBADD = -lkio $(LIBRPC)
+kio_nfs_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+noinst_HEADERS = nfs_prot.h mount.h
+
+kdelnk_DATA = nfs.protocol
+kdelnkdir = $(kde_servicesdir)
+
+METASOURCES = AUTO
+
+$(srcdir)/mount_xdr.c: $(srcdir)/mount.x
+ cd $(srcdir) && rpcgen ./mount.x
+
+
+$(srcdir)/nfs_prot_xdr.c: $(srcdir)/nfs_prot.x
+ cd $(srcdir) && rpcgen ./nfs_prot.x
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_nfs.pot