summaryrefslogtreecommitdiffstats
path: root/tdeioslave/nntp/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
commitde7e5867a65e0a46f1388e3e50bc7eeddd1aecbf (patch)
treedbb3152c372f8620f9290137d461f3d9f9eba1cb /tdeioslave/nntp/Makefile.am
parent936d3cec490c13f2c5f7dd14f5e364fddaa6da71 (diff)
downloadtdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.tar.gz
tdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/nntp/Makefile.am')
-rw-r--r--tdeioslave/nntp/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tdeioslave/nntp/Makefile.am b/tdeioslave/nntp/Makefile.am
new file mode 100644
index 000000000..a48a7de80
--- /dev/null
+++ b/tdeioslave/nntp/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES= -I$(srcdir)/../.. -I$(srcdir)/.. $(all_includes)
+
+####### Files
+
+kde_module_LTLIBRARIES = kio_nntp.la
+
+kio_nntp_la_SOURCES = nntp.cpp
+kio_nntp_la_LIBADD = $(LIB_KIO)
+kio_nntp_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+METASOURCES = AUTO
+
+noinst_HEADERS = nntp.h
+
+kdelnk_DATA = nntp.protocol nntps.protocol
+kdelnkdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_nntp.pot