summaryrefslogtreecommitdiffstats
path: root/tdeioslave/trash/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
commitde7e5867a65e0a46f1388e3e50bc7eeddd1aecbf (patch)
treedbb3152c372f8620f9290137d461f3d9f9eba1cb /tdeioslave/trash/Makefile.am
parent936d3cec490c13f2c5f7dd14f5e364fddaa6da71 (diff)
downloadtdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.tar.gz
tdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/trash/Makefile.am')
-rw-r--r--tdeioslave/trash/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tdeioslave/trash/Makefile.am b/tdeioslave/trash/Makefile.am
new file mode 100644
index 000000000..dae7debd5
--- /dev/null
+++ b/tdeioslave/trash/Makefile.am
@@ -0,0 +1,31 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+SUBDIRS = . tdefile-plugin
+
+kde_module_LTLIBRARIES = kio_trash.la
+
+kio_trash_la_SOURCES = kio_trash.cpp
+kio_trash_la_LIBADD = libtrashcommon.la $(LIB_KIO)
+kio_trash_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+
+bin_PROGRAMS = ktrash
+ktrash_SOURCES = ktrash.cpp
+ktrash_LDADD = $(LIB_KIO)
+ktrash_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+
+kde_services_DATA = trash.protocol
+
+noinst_LTLIBRARIES = libtrashcommon.la
+libtrashcommon_la_SOURCES = trashimpl.cpp
+
+check_PROGRAMS = testtrash
+testtrash_SOURCES = testtrash.cpp
+testtrash_LDADD = libtrashcommon.la $(LIB_KIO)
+testtrash_LDFLAGS = $(all_libraries)
+
+TESTS = testtrash
+
+messages:
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp" -o -name "*.h"` -o $(podir)/tdeio_trash.pot
+