summaryrefslogtreecommitdiffstats
path: root/tdeioslave/trash/Makefile.am
diff options
context:
space:
mode:
authorEmanoil Kotsev <deloptes@gmail.com>2016-10-12 15:20:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2016-10-12 15:20:02 +0900
commitee3091bc41f5cae8be2ba5f8335e0b866edb4711 (patch)
tree8ffc7ba391bb968e9de33674fa6caf5e9166e5eb /tdeioslave/trash/Makefile.am
parent443c910570647f415838e65a1b8add30b00b7dbb (diff)
downloadtdebase-ee3091bc41f5cae8be2ba5f8335e0b866edb4711.tar.gz
tdebase-ee3091bc41f5cae8be2ba5f8335e0b866edb4711.zip
Added trash limit configuration option
This work is based on original patch created by Tobias Koenig <tokoe@kde.org> for KDE 3.5.9 and later added to KDE 4.2, and available under GPL version 2 License, or any later version. See also http://tokoe-kde.blogspot.com/2008/08/size-limits-for-trash.html This relates to bug 1923. Signed-off-by: Emanoil Kotsev <deloptes@gmail.com> Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'tdeioslave/trash/Makefile.am')
-rw-r--r--tdeioslave/trash/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/tdeioslave/trash/Makefile.am b/tdeioslave/trash/Makefile.am
index 02b43e90a..a3c8253e0 100644
--- a/tdeioslave/trash/Makefile.am
+++ b/tdeioslave/trash/Makefile.am
@@ -3,7 +3,7 @@ METASOURCES = AUTO
SUBDIRS = . tdefile-plugin
-kde_module_LTLIBRARIES = tdeio_trash.la
+kde_module_LTLIBRARIES = tdeio_trash.la ktrashpropsdlgplugin.la
tdeio_trash_la_SOURCES = tdeio_trash.cpp
tdeio_trash_la_LIBADD = libtrashcommon.la $(LIB_TDEIO)
@@ -17,7 +17,7 @@ ktrash_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $
kde_services_DATA = trash.protocol
noinst_LTLIBRARIES = libtrashcommon.la
-libtrashcommon_la_SOURCES = trashimpl.cpp
+libtrashcommon_la_SOURCES = trashimpl.cpp discspaceutil.cpp
check_PROGRAMS = testtrash
testtrash_SOURCES = testtrash.cpp
@@ -29,3 +29,12 @@ TESTS = testtrash
messages:
$(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp" -o -name "*.h"` -o $(podir)/tdeio_trash.pot
+# ktrashpropsdlgplugin target
+noinst_HEADERS = ktrashpropsdlgplugin.h discspaceutil.h
+
+ktrashpropsdlgplugin_la_SOURCES = ktrashpropsdlgplugin.cpp discspaceutil.cpp trashimpl.cpp
+ktrashpropsdlgplugin_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+ktrashpropsdlgplugin_la_LIBADD = $(LIB_TDEIO)
+
+services_DATA = ktrashpropsdlgplugin.desktop
+servicesdir = $(kde_servicesdir)