summaryrefslogtreecommitdiffstats
path: root/tdeprint/tdeprint_part/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:34 -0600
commitb529f046c9a64ac5fcfa60747af940cf972b3ebc (patch)
tree83c28cf7fa8fed1960ebd3924b579e7ed8c95cc6 /tdeprint/tdeprint_part/CMakeLists.txt
parent6508fe4c40c60fd7a43bd3d9e19b762e10ea3f53 (diff)
downloadtdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.tar.gz
tdebase-b529f046c9a64ac5fcfa60747af940cf972b3ebc.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/tdeprint_part/CMakeLists.txt')
-rw-r--r--tdeprint/tdeprint_part/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tdeprint/tdeprint_part/CMakeLists.txt b/tdeprint/tdeprint_part/CMakeLists.txt
new file mode 100644
index 000000000..6de7ddb91
--- /dev/null
+++ b/tdeprint/tdeprint_part/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions( -D_KDEPRINT_COMPILE )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES tdeprint_part.rc DESTINATION ${DATA_INSTALL_DIR}/tdeprint_part )
+install( FILES tdeprint_part.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### libtdeprint_part (module) #################
+
+tde_add_kpart( libtdeprint_part AUTOMOC
+ SOURCES printpart.cpp
+ LINK tdeprint_management-shared kparts-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)