summaryrefslogtreecommitdiffstats
path: root/tqt3integration/module/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-19 18:56:47 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-19 18:56:47 +0000
commit337f18fe5d032a59084a5d6516bcb0ff070128b6 (patch)
treeb8e5fa7014c3aa5672f15c86ddba5e53462d6f6f /tqt3integration/module/CMakeLists.txt
parent1944004a4c57c4c87efc66084579b595da720af8 (diff)
downloadtdebase-337f18fe5d032a59084a5d6516bcb0ff070128b6.tar.gz
tdebase-337f18fe5d032a59084a5d6516bcb0ff070128b6.zip
Add tqt3integration
These files were originally taken from the GPLed OpenSUSE kdebase builds git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1259731 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'tqt3integration/module/CMakeLists.txt')
-rw-r--r--tqt3integration/module/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tqt3integration/module/CMakeLists.txt b/tqt3integration/module/CMakeLists.txt
new file mode 100644
index 000000000..282c4a6a3
--- /dev/null
+++ b/tqt3integration/module/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tqt3integration/utils/
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### service desktop file(s) ##########################
+
+install( FILES kdeintegration.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+
+##### kded_kdeintegration (module) #####################
+
+set( target kded_kdeintegration )
+
+set( ${target}_SRCS
+ module.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK kdeinit_kded-shared
+ DEPENDENCIES generate_tqt3_bindings
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+) \ No newline at end of file