summaryrefslogtreecommitdiffstats
path: root/twin/compton-tde/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2014-04-07 00:41:17 +0400
committerSlávek Banko <slavek.banko@axis.cz>2014-04-29 01:54:05 +0200
commit30252262ce90415f09232c51724a393c8dd6a7fe (patch)
tree7b1585a127436ef4c88d37a877013f759c51e652 /twin/compton-tde/CMakeLists.txt
parent394545c24c0e31d84ccb3d008c8da7c2e1f06451 (diff)
downloadtdebase-30252262ce90415f09232c51724a393c8dd6a7fe.tar.gz
tdebase-30252262ce90415f09232c51724a393c8dd6a7fe.zip
Move the Xinerama test to main ConfigureChecks.cmake
Diffstat (limited to 'twin/compton-tde/CMakeLists.txt')
-rw-r--r--twin/compton-tde/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/twin/compton-tde/CMakeLists.txt b/twin/compton-tde/CMakeLists.txt
index f73f09ee5..6a2d71339 100644
--- a/twin/compton-tde/CMakeLists.txt
+++ b/twin/compton-tde/CMakeLists.txt
@@ -31,6 +31,8 @@ include_directories(
# WITH_XINNERAMA -> CONFIG_XINERAMA
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL
# WITH_OPENGL -> CONFIG_VSYNC_OPENGL_GLSL
+# WITH_OPENGL -> CONFIG_VSYNC_OPENGL_FBO
+# WITH_OPENGL -> CONFIG_GLX_XSYNC
# WITH_PCRE -> CONFIG_REGEX_PCRE
# WITH_PCRE -> CONFIG_REGEX_PCRE_JIT
# WITH_LIBCONFIG -> CONFIG_LIBCONFIG
@@ -50,6 +52,8 @@ set( compton_SRCS compton.c )
if( WITH_OPENGL )
set( CONFIG_VSYNC_OPENGL ${WITH_OPENGL} )
set( CONFIG_VSYNC_OPENGL_GLSL ${WITH_OPENGL} )
+ set( CONFIG_VSYNC_OPENGL_FBO ${WITH_OPENGL} )
+ set( CONFIG_GLX_XSYNC ${WITH_OPENGL} )
list( APPEND compton_LIBRARIES ${GL_LIBRARIES})
list( APPEND compton_SRCS opengl.c )
endif( )