summaryrefslogtreecommitdiffstats
path: root/doc/khelpcenter/license/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/khelpcenter/license/CMakeLists.txt')
-rw-r--r--doc/khelpcenter/license/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/doc/khelpcenter/license/CMakeLists.txt b/doc/khelpcenter/license/CMakeLists.txt
new file mode 100644
index 000000000..ee0dfb94b
--- /dev/null
+++ b/doc/khelpcenter/license/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES tde_license_info.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
+
+
+##### tde_license_info (executable) #########################
+
+tde_add_executable( tde_license_info AUTOMOC
+ SOURCES mainWindow.cpp TDELicenseDlg.cpp
+ LINK tdeui-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)