summaryrefslogtreecommitdiffstats
path: root/kcontrol/joystick/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/joystick/Makefile.am')
-rw-r--r--kcontrol/joystick/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kcontrol/joystick/Makefile.am b/kcontrol/joystick/Makefile.am
new file mode 100644
index 000000000..269dec101
--- /dev/null
+++ b/kcontrol/joystick/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = kcm_joystick.la
+
+kcm_joystick_la_SOURCES = joystick.cpp joywidget.cpp poswidget.cpp joydevice.cpp caldialog.cpp
+kcm_joystick_la_LIBADD = $(LIB_KDEUI)
+kcm_joystick_la_LDFLAGS = -module -avoid-version $(all_libraries) -no-undefined
+
+xdg_apps_DATA = joystick.desktop
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/joystick.pot
+
+noinst_HEADERS = joywidget.h joywidget.h poswidget.h joydevice.h caldialog.h
+