summaryrefslogtreecommitdiffstats
path: root/kcontrol/knotify/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/knotify/CMakeLists.txt')
-rw-r--r--kcontrol/knotify/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/kcontrol/knotify/CMakeLists.txt b/kcontrol/knotify/CMakeLists.txt
new file mode 100644
index 000000000..1a5b81ca2
--- /dev/null
+++ b/kcontrol/knotify/CMakeLists.txt
@@ -0,0 +1,36 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( sounds )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### other data ################################
+
+install( FILES kcmnotify.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES play.png DESTINATION ${DATA_INSTALL_DIR}/kcontrol/pics )
+
+
+##### kcm_knotify (module) ######################
+
+tde_add_kpart( kcm_knotify AUTOMOC
+ SOURCES knotify.cpp playersettings.ui
+ LINK kio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)