summaryrefslogtreecommitdiffstats
path: root/kcontrol/nics/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/nics/Makefile.am')
-rw-r--r--kcontrol/nics/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kcontrol/nics/Makefile.am b/kcontrol/nics/Makefile.am
new file mode 100644
index 000000000..9cd225329
--- /dev/null
+++ b/kcontrol/nics/Makefile.am
@@ -0,0 +1,15 @@
+kde_module_LTLIBRARIES = kcm_nic.la
+
+kcm_nic_la_SOURCES = nic.cpp
+
+kcm_nic_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_nic_la_LIBADD = -lkdeui $(LIB_KIO) $(LIBSOCKET)
+
+AM_CPPFLAGS= $(all_includes)
+
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) $(kcm_nic_la_SOURCES) -o $(podir)/kcmnic.pot
+
+xdg_apps_DATA = nic.desktop