summaryrefslogtreecommitdiffstats
path: root/kdesktop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdesktop/Makefile.am')
-rw-r--r--kdesktop/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/kdesktop/Makefile.am b/kdesktop/Makefile.am
index fecd9e9c4..cf31fce0a 100644
--- a/kdesktop/Makefile.am
+++ b/kdesktop/Makefile.am
@@ -8,7 +8,7 @@ SUBDIRS = . lock pics patterns programs init kwebdesktop
####### Files
-bin_PROGRAMS = kcheckrunning
+bin_PROGRAMS = kcheckrunning kxdglauncher
lib_LTLIBRARIES =
kdeinit_LTLIBRARIES = kdesktop.la
noinst_LTLIBRARIES = libkdesktopsettings.la
@@ -31,12 +31,16 @@ include_HEADERS = KDesktopIface.h KScreensaverIface.h KBackgroundIface.h
noinst_HEADERS = desktop.h bgmanager.h krootwm.h \
xautolock.h lockeng.h init.h minicli.h \
pixmapserver.h startupid.h xautolock_c.h \
- kdesktopapp.h
+ kdesktopapp.h kxdglauncher.h
kcheckrunning_SOURCES = kcheckrunning.cpp
kcheckrunning_LDFLAGS = $(all_libraries)
kcheckrunning_LDADD = $(LIB_X11)
+kxdglauncher_SOURCES = kxdglauncher.cpp
+kxdglauncher_LDFLAGS = $(all_libraries)
+kxdglauncher_LDADD = $(LIB_KUTILS)
+
METASOURCES = AUTO
####### Build rules